2

I have a Broadcom BCM2046, it appears as connected in the bluetooth widget over the panel, and the hcitools drops me data, but it doesn't work at all, I've tried to connect from another device and it's inexistent and viceversa from PC to the device

hcitool dev and lsusb

hci0:   Type: BR/EDR  Bus: USB
BD Address: 89:21:09:79:B5:1B  ACL MTU: 1017:8  SCO MTU: 64:0
UP RUNNING PSCAN ISCAN 
RX bytes:779 acl:0 sco:0 events:27 errors:0
TX bytes:376 acl:0 sco:0 commands:27 errors:0

Bus 001 Device 007: ID 0a5c:4500 Broadcom Corp. BCM2046B1 USB 2.0 Hub (part of       BCM2046 Bluetooth)
Bus 001 Device 008: ID 0a5c:2100 Broadcom Corp. Bluetooth 2.0+eDR dongle
5

Open up a terminal from Applications -> Accessories. Type:

sudo gedit /etc/modules

At the bottom of the file, make two new lines, like this:

usbserial
option

Then close the editor program and save it. Reboot the computer and hopefully you’ll be right from now on!

4

This worked for me

sudo hciconfig hci0 reset

Source : https://askubuntu.com/a/204427/69743

Running Gnome-Ubuntu 13.10

  • 1
    Works on Kubuntu 14.04 – Manck Aug 8 '14 at 19:24
  • 1
    I had to run rfkill unblock all and hciconfig hci0 up first, but this worked (except my device was hci1 instead of hci0 which one can find by hcitool dev). – virtualxtc May 15 '17 at 23:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.