3

The keyboard layout GUI in 12.04 system settings is not responding on my laptop. In a different post a workaround was found (see: Cannot switch keyboard layouts).

Problem now: Having manually altered the file /etc/default/keyboard I can now access all the keyboard layouts I want except for one: Russian phonetic. (i.e. the letters are placed where the equivalent Latin letters are - qwerty) This keyboard was in the old Gnome and it is still listed in the "system settings" keyboard GUI. But the GUI is not responding.

I can toggle between the official Russian keyboard and Norwegian with the command:

sudo setxkbmap -option grp:alt_shift_toggle no,ru

But ru phonetic is not understood. What is the code for the phonetic Russian keyboard?

1

I use it like that:

setxkbmap -option grp:switch,grp:alt_shift_toggle,grp_led:scroll,compose:menu -layout 'us,lt,ru' -variant ',,phonetic_winkeys'

The main thing is 'us,lt,ru' and ',,phonetic_winkeys'. In your case it will be -variant ',phonetic_winkeys'

protected by N0rbert Nov 10 '18 at 20:33

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.