1

I edited the /etc/pulse/daemon.conf to make it 6:

stephen@stephen-Aspire-TC-605:~/$ cat /etc/pulse/daemon.conf | grep channel
; remixing-use-all-sink-channels = yes
default-sample-channels = 6
; default-channel-map = front-left,front-right

after restarting I still get only stereo in the sound settings. installed the pavucontrol and still nothing. the 5.1 is connected with three jacks on the back, not hdmi. Something is missing

tephen@stephen-Aspire-TC-605:~$ speaker-test -Dplug:surround51 -c6 -l1 -twav

speaker-test 1.2.2

Playback device is plug:surround51
Stream parameters are 48000Hz, S16_LE, 6 channels
WAV file(s)
Playback open error: -2,No such file or directory
tephen@stephen-Aspire-TC-605:~$ aplay -L |grep 5.*1
surround51
    5.1 Surround output to Front, Center, Rear and Subwoofer speakers
surround51:CARD=PCH,DEV=0
    5.1 Surround output to Front, Center, Rear and Subwoofer speakers

... with many rows about hdmi, dmix and dsnoop

1

Assuming you have true 5.1 speakers and they are properly connected:

From etc/pulse/, copy daemon.conf and default.pa to your user's home folder. (If you've altered these configs previously, copy from your backup of the original files):

cp /etc/pulse/daemon.conf ~/.config/pulse/daemon.conf
cp /etc/pulse/default.pa ~/.config/pulse/default.pa

Add the following line to ~/.config/pulse/default.pa:

load-module module-combine channels=6 channel_map=front-left,front-right,rear-left,rear-right,front-center,lfe

Add (or uncomment) the following lines in ~/.config/pulse/daemon.conf:

remixing-produce-lfe = yes
remixing-consume-lfe = yes
lfe-crossover-freq = 80

Without the lfe-crossover-freq defined, it defaults to 0, which is not very helpful.

You can replace 80 with the desired crossover frequency (in Hz). Frequencies below this value will be sent to the LFE channel. Frequencies between 80Hz - 120Hz are generally recommended for the LFE crossover.

To enable the new settings, restart pulse with pulseaudio -k. Some applications could require a restart.

1
0

I found it. start alsamixer and then hit F6 to select sound card. select HDA Intel PCH and then you see this:

alsamixer

then click right arrow until you get to the channels and click up arrow to set it to 6 channel

alsamixer

Now you will get the full surround mode and it works great. I did that after making the changes suggested in the previous answer, so do that too. But choosing the card and changing the channels in alsa is crucial.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.