0

My aspect ratio is annoying and not normal, so I did the following commands:

cvt 1280 720
xrandr --newmode "1280x720_60.00 -hsync +vsync
xrandr --addmode default 1280x720_60.00
xrandr --output default --mode 1280x720_60.00

To which I get the following comand:

xrandr: Failed to get size of gamma for output default xrandr: Configure crtc 0 failed

After some internet searching, I then wrote

xrandr --output default --mode 1280x720_60.00 --brightness 0.7 --gamma 0.3:0.3:0.3

But now I get:

Gamma Size is 0

I then went on to Arandr, and the resolution I set is there, but when I try to switch it, it will glitch the screen for a split second then say "Configure crtc 0 failed".

Any help would be appreciated, but apologies for any grammatical errors, English is not my first language.

This is what I get from --verbose:

xrandr: Failed to get size of gamma for output default
Screen 0: minimum 1024 x 768, current 1024 x 768, maximum 1024 x 768
default connected primary 1024x768+0+0 (0x399) normal (normal) 0mm x 
0mm
Identifier: 0x398
Timestamp:  83296
Subpixel:   unknown
Clones:    
CRTC:       0
CRTCs:      0
Transform:  1.000000 0.000000 0.000000
            0.000000 1.000000 0.000000
            0.000000 0.000000 1.000000
           filter: 
_MUTTER_PRESENTATION_OUTPUT: 0 
non-desktop: 0 
    supported: 0, 1

1024x768 (0x399) 59.769MHz *current h: width 1024 start 0 end 0 total 1024 skew 0 clock 58.37KHz v: height 768 start 0 end 0 total 768 clock 76.00Hz

1 Answer 1

0

Do you have multiple output devices? You will probably need to specify the crtc number when setting the resolution.

First get your crtc number with:

xrandr --verbose

Now make this part of the command:

xrandr --output CRT1 --crtc CRT1 --mode 1280x720_60.00 --brightness 0.7 --gamma 0.3:0.3:0.3

Remember to change CRT1 to the value you receive from the --verbose output.

That should do it.

1
  • 2
    I have one output device which is my monitor (running on VGA). and when I do "xrandr --verbose" I get the output that is written on the original question. Which part of that is the value I should replace the CRT1 with? Thanks
    – OHTYCH 100
    Commented Dec 30, 2020 at 19:52

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .