0

I am running a Toshiba Satellite L745 with Ubuntu 20.04. Seconds after I put the machine to sleep or close the lid, it wakes up by itself. I have disabled all wake up options listed in the BIOS.

Output of: cat /proc/acpi/wakeup | grep enabled

EHC1 S3 *enabled pci:0000:00:1d.0
EHC2 S3 *enabled pci:0000:00:1a.0

ECH1/ECH2 will not toggle to disabled. These lines refer to two USB Host controllers per: lspci command. Not sure where to go from here.

I also read in forums for the issue of machine not going into deep sleep.

Output of: cat /sys/power/mem_sleep s2idle [deep] Seems it is in the correct mode.

Per request see the syslog below of relevent logs relating to suspend. Not too familiar with the suspend process...the last line is the only line that says wake requested, but CPU's came back up prior to this line. Any help deciphering this is much appreciated.

Jan  3 18:36:42 joe systemd[1]: Starting Suspend...
Jan  3 18:36:42 joe systemd-sleep[4530]: Suspending system...
Jan  3 18:36:42 joe kernel: [ 1528.423899] PM: suspend entry (deep)
Jan  3 18:36:48 joe kernel: [ 1529.134360] Filesystems sync: 0.710 seconds
Jan  3 18:36:48 joe kernel: [ 1529.134830] Freezing user space processes ... (elapsed 0.005 seconds) done.
Jan  3 18:36:48 joe kernel: [ 1529.139944] OOM killer disabled.
Jan  3 18:36:48 joe kernel: [ 1529.139946] Freezing remaining freezable tasks ... (elapsed 0.001 seconds) done.
Jan  3 18:36:48 joe kernel: [ 1529.141431] printk: Suspending console(s) (use no_console_suspend to debug)
Jan  3 18:36:48 joe kernel: [ 1529.157933] sd 0:0:0:0: [sda] Synchronizing SCSI cache
Jan  3 18:36:48 joe kernel: [ 1529.298187] sd 0:0:0:0: [sda] Stopping disk
Jan  3 18:36:48 joe kernel: [ 1529.946471] ACPI: EC: interrupt blocked
Jan  3 18:36:48 joe kernel: [ 1529.966401] ACPI: Preparing to enter system sleep state S3
Jan  3 18:36:48 joe kernel: [ 1529.967350] ACPI: EC: event blocked
Jan  3 18:36:48 joe kernel: [ 1529.967352] ACPI: EC: EC stopped
Jan  3 18:36:48 joe kernel: [ 1529.967354] PM: Saving platform NVS memory
Jan  3 18:36:48 joe kernel: [ 1529.967377] Disabling non-boot CPUs ...
Jan  3 18:36:48 joe kernel: [ 1529.968119] IRQ 17: no longer affine to CPU1
Jan  3 18:36:48 joe kernel: [ 1529.969178] smpboot: CPU 1 is now offline
Jan  3 18:36:48 joe kernel: [ 1529.973680] IRQ 29: no longer affine to CPU2
Jan  3 18:36:48 joe kernel: [ 1529.974714] smpboot: CPU 2 is now offline
Jan  3 18:36:48 joe kernel: [ 1529.978105] IRQ 16: no longer affine to CPU3
Jan  3 18:36:48 joe kernel: [ 1529.978120] IRQ 23: no longer affine to CPU3
Jan  3 18:36:48 joe kernel: [ 1529.979138] smpboot: CPU 3 is now offline
Jan  3 18:36:48 joe kernel: [ 1529.981806] ACPI: Low-level resume complete
Jan  3 18:36:48 joe kernel: [ 1529.981856] ACPI: EC: EC started
Jan  3 18:36:48 joe kernel: [ 1529.981857] PM: Restoring platform NVS memory
Jan  3 18:36:48 joe kernel: [ 1529.983250] Enabling non-boot CPUs ...
Jan  3 18:36:48 joe kernel: [ 1529.983307] x86: Booting SMP configuration:
Jan  3 18:36:48 joe kernel: [ 1529.983308] smpboot: Booting Node 0 Processor 1 APIC 0x1
Jan  3 18:36:48 joe kernel: [ 1529.986443] CPU1 is up
Jan  3 18:36:48 joe kernel: [ 1529.986516] smpboot: Booting Node 0 Processor 2 APIC 0x2
Jan  3 18:36:48 joe kernel: [ 1529.990130] CPU2 is up
Jan  3 18:36:48 joe kernel: [ 1529.990214] smpboot: Booting Node 0 Processor 3 APIC 0x3
Jan  3 18:36:48 joe kernel: [ 1529.993589] CPU3 is up
Jan  3 18:36:48 joe kernel: [ 1530.001938] ACPI: Waking up from system sleep state S3
Jan  3 18:36:48 joe kernel: [ 1530.002791] ACPI: EC: interrupt unblocked
Jan  3 18:36:48 joe kernel: [ 1530.039617] ACPI: EC: event unblocked
Jan  3 18:36:48 joe kernel: [ 1530.039771] rtlwifi: rtlwifi: wireless switch is on
Jan  3 18:36:48 joe kernel: [ 1530.049980] sd 0:0:0:0: [sda] Starting disk
Jan  3 18:36:48 joe kernel: [ 1530.287009] usb 2-1.5: reset high-speed USB device number 3 using ehci-pci
Jan  3 18:36:48 joe kernel: [ 1530.294975] usb 1-1.4: reset high-speed USB device number 3 using ehci-pci
Jan  3 18:36:48 joe kernel: [ 1530.386368] ata4: SATA link down (SStatus 0 SControl 300)
Jan  3 18:36:48 joe kernel: [ 1530.386419] ata5: SATA link up 1.5 Gbps (SStatus 113 SControl 300)
Jan  3 18:36:48 joe kernel: [ 1530.395672] ata5.00: configured for UDMA/100
Jan  3 18:36:48 joe kernel: [ 1530.449372] OOM killer enabled.
Jan  3 18:36:48 joe kernel: [ 1530.449375] Restarting tasks ... done.
Jan  3 18:36:48 joe systemd[1409]: vte-spawn-e52498e8-c196-4beb-9d33-2892897d288a.scope: Succeeded.
Jan  3 18:36:48 joe kernel: [ 1530.856428] psmouse serio2: synaptics: queried max coordinates: x [..5686], y [..4786]
Jan  3 18:36:48 joe kernel: [ 1530.883491] PM: suspend exit
Jan  3 18:36:48 joe systemd-sleep[4530]: System resumed.
Jan  3 18:36:50 joe kernel: [ 1532.242920] ata1: SATA link up 3.0 Gbps (SStatus 123 SControl 300)
Jan  3 18:36:50 joe kernel: [ 1532.244931] ata1.00: configured for UDMA/100
Jan  3 18:36:50 joe systemd-sleep[4628]: /dev/sda:
Jan  3 18:36:50 joe systemd-sleep[4628]:  setting Advanced Power Management level to 0x80 (128)
Jan  3 18:36:50 joe systemd-sleep[4628]:  APM_level#011= 128
Jan  3 18:36:50 joe systemd-sleep[4672]: /dev/sda:
Jan  3 18:36:50 joe systemd-sleep[4672]:  setting standby to 36 (3 minutes)
Jan  3 18:36:50 joe systemd[1]: systemd-suspend.service: Succeeded.
Jan  3 18:36:50 joe systemd[1]: Finished Suspend.
Jan  3 18:36:50 joe systemd[1]: Stopped target Sleep.
Jan  3 18:36:50 joe systemd[1]: Reached target Suspend.
Jan  3 18:36:50 joe systemd[1]: Stopped target Suspend.
Jan  3 18:36:50 joe NetworkManager[718]: <info>  [1609717010.3905] manager: sleep: wake requested (sleeping: yes  enabled: yes)

I recently re-installed Ubuntu mainly to try and fix this (and other) issues. The machine has a fresh install, no alterations to default settings.

Any further troubleshooting steps would be much appreciated.

Thank you,

Joe

2
  • Check /var/log/syslog at the time you suspended and post any likely reasons into your question. – WinEunuuchs2Unix Jan 3 at 16:49
  • Posted the syslog. Not sure I see anything obviously causing the issue – Joe T Jan 13 at 22:30
1

I had a similar problem which I reported in an on-going bug report

For me the solution was in this answer:

I'm still using that old answer today, however I'm using the second script in the answer: /lib/systemd/system-sleep/custom-xhci_hcd.

Every now and then I turn the script off but something unusual happens and I have to turn the script back on. I can't fully explain why there are problems in suspend/resume so when I find something that works I just stick to it.

2
  • I created the script as described and it worked! Thank you for the help! – Joe T Jan 16 at 0:15
  • @JoeT I'm glad it helped you. It puts a smile on my face :) – WinEunuuchs2Unix Jan 16 at 0:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.