0

This is my first question to the community so be kind with me if not properly presented :-)

New to Linux (20.04 installed), I am testing various e-mail clients. I really like Geary, but there is an annoying issue with spell checks, that propose only English variations and I need french on top.

In the Activities/setting menus, french is present, so is in Libreoffice writer and in Thundermail.

I researched on the web but did not find any precise response

Many Thanks

4 Answers 4

0

Welcome to AskUbuntu Thierry,

Geary can use a couple of different dictionary sources and hunspell is generally the best one for people who use non-English languages. If you haven’t done so already, you can install hunspell like this:

sudo apt install hunspell hunspell-fr

This will install the dictionary as well as the main French dictionary. From there you can restart Geary. French should then appear n the available languages list.

Hope this answers your question 👍🏻

5
  • Many thanks Matigo. Could not install hunspell-fr as it was already present. problem is still the same problem. 18 versions of english but not french in Geary
    – Thierry
    Dec 28, 2020 at 4:02
  • Which version of Geary are you running? Is it a snap or flatpak version? 🤔
    – user1091774
    Dec 28, 2020 at 4:04
  • flatpak, geary 3.38.1
    – Thierry
    Dec 28, 2020 at 4:08
  • Have you run a flatpak update recently?
    – user1091774
    Dec 28, 2020 at 6:09
  • yes - no update needed
    – Thierry
    Dec 28, 2020 at 14:29
0

Problem solved :). I des-installed Geary, changed back the main Activities/settings default to French, rebooted then re-installed Geary. French has been added to English in the spell check options of Geary, then change the main Activities/Settings back to English

0

I've been there too, and changing the locale after installing new flatpak app to get the language does solve the problem, but there's better solution, involving a bit of terminal.

Just two commands:

flatpak config --set extra-languages "fr_FR"
flatpak update

This will make your further flatpak installation obey and install French for any new app.

0

I was not able to get spell check initially, after installing aspell and aspell-en, and reboot, it worked. So I assume if you install aspell-xx and reboot, it should work. I never got hunsepll to work.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.