2

I have already struggled with multiple attempts to fix this issue. First I thought its a problem with UEFI as I have experienced that some computers cant boot some drivers if not legacy boot, but that was not the case. I also cannot find any alternative drivers.

I have an uptodate version of Linux Mint freshly installed on it.

Back before i solved it touchpad also did not show up on my xinoutput command

1
  • 1
    Linux Mint is off-topic at this site.
    – Pilot6
    Dec 27, 2020 at 15:03

1 Answer 1

5

To solve touchpad issues I have come acress multiple forums that suggested to write something different in /etc/default/grub and then run sudo update-grub

Currently I have edited it to be this:

GRUB_DEFAULT=0
GRUB_TIMEOUT_STYLE=hidden
GRUB_TIMEOUT=0
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash snd_hda_intel.dmic_detect=0 i8042.nopnp=1 pci=nocrs"
GRUB_CMDLINE_LINUX="initcall_blacklist=elants_i2c_driver_init"

since I tried many configurations from this forum and this forum, yet I do not manage to get it to work. This is my output for xinput

$ xinput
⎡ Virtual core pointer                      id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ Avago USB LaserStream(TM) Mouse           id=10   [slave  pointer  (2)]
⎜   ↳ MSFT0001:01 06CB:CE2D Mouse               id=11   [slave  pointer  (2)]
⎜   ↳ MSFT0001:01 06CB:CE2D Touchpad            id=12   [slave  pointer  (2)]
⎣ Virtual core keyboard                     id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
    ↳ Power Button                              id=6    [slave  keyboard (3)]
    ↳ Video Bus                                 id=7    [slave  keyboard (3)]
    ↳ Power Button                              id=8    [slave  keyboard (3)]
    ↳ Ideapad extra buttons                     id=13   [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard              id=14   [slave  keyboard (3)]
    ↳ Integrated Camera: Integrated C           id=9    [slave  keyboard (3)]

And now for some reason my touchpad works for the first time so I share with you guys this grub file that worked for me.

2
  • I don't thin the i8042.nopnp=1 is needed, only the "blacklist" and the pci=nocrs entries, at least according to my experience.
    – rik-shaw
    Feb 21, 2021 at 7:27
  • 1
    Also have the IdeaPad 3, and touchpad was not working. Did not work without i8042.nopnp=1. Problem solved. Note, its reported the Fedora 30 works.
    – wbg
    Feb 25, 2021 at 23:03

Not the answer you're looking for? Browse other questions tagged or ask your own question.