6

When running htop I get

Error: File /etc/sensors3.conf: Permission denied

the permissions:

$ ls -l /etc/sensors3.conf
-rw-r--r-- 1 root root 10368 Apr  5  2017 /etc/sensors3.conf

htop still works as expected, but what's up with this error?

I've also tried:

sudo apt install --reinstall lm-sensors

which made no difference.

which htop
/usr/bin/htop
3
  • which htop please. Maybe it is a snap? – nobody Dec 27 '20 at 13:56
  • it looks like not. I recall that I did install with apt. – ezekiel Dec 27 '20 at 14:33
  • Maybe run sudo htop, i think it's unsafe when you run as superuser but give it a try. – yang mandi Dec 30 '20 at 17:20
7

Snap maintainer here. That's just a warning message caused by missing permissions due to snap confinement. As a result, optional CPU temperature stats are unavailable (N/A is shown to the right of each CPU bar, if enabled).

Just updated the snap with support for manually connecting the hardware-observe interface, which fixes it (and also adds support for battery stats, btw). So, you just need to:

$ sudo snap connect htop:hardware-observe

Also, before just uninstalling the snap, note that depending on your OS release the snap might be much newer than the one in the OS repositories (eg. 3.0.4 vs 2.1.0 on Ubuntu 18.04).

0

I had the same problem even after install with apt and fixed it by removing the snap version of htop.

sudo snap remove htop
1

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.