2

When I try to update from 18.04 to 20.04 via

sudo do-release-upgrade

I get the message:

Please install all available updates for your release before upgrading.

I have followed the advice here from Pitt79

Can't upgrade Ubuntu 18.04 to 20.04 because of "Please install all available updates for your release before upgrading" error

to copy and modify /usr/bin/do-release-upgrade so that it displays which repositories need to be deleted, in my case: colord sane simple-scan skanlite

I deleted sane, simple-scan and skanlite via Synaptic Package Manager. However, if I want to delete colord Synaptic Package Manager says Ubuntu Desktop will also be deleted.

Another user reports having done this

https://itectec.com/ubuntu/ubuntu-ubuntu-20-04-1-upgrade-failure-error-dist-upgrade-failed-broken-packages-after-upgrade-colord/

However, I am reluctant to go down this path.

I would be grateful for any advice.

The result from apt policy colord is as follows:

result from apt policy colord

The result from sudo apt upgrade:

laurence@LaurencePC1:~$ sudo apt upgrade
[sudo] password for laurence: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
The following packages were automatically installed and are no longer required:
  fonts-dejavu kde-runtime kde-runtime-data kde-style-breeze
  kde-style-breeze-qt4 kdelibs-bin kdelibs5-data kdelibs5-plugins kdoctools
  libattica0.4 libdlrestrictions1 libgpgme++2v5 libkactivities6 libkcmutils4
  libkde3support4 libkdeclarative5 libkdecore5 libkdesu5 libkdeui5
  libkdewebkit5 libkdnssd4 libkemoticons4 libkf5sane-data libkf5style5
  libkfile4 libkhtml5 libkio5 libkjsapi4 libkjsembed4 libkmediaplayer4
  libknewstuff3-4 libknotifyconfig4 libkntlm4 libkparts4 libkpty4
  libkrosscore4 libksane-data libksane0 libktexteditor4 libkxmlrpcclient4
  libntrack-qt4-1 libntrack0 libpackagekit-glib2-16 libphonon4 libplasma3
  libpolkit-qt-1-1 libqca2 libqca2-plugins libqt4-designer libqt4-qt3support
  libqt4-svg libqtwebkit4 libsolid4 libstreamanalyzer0v5 libstreams0v5
  libthreadweaver4 ntrack-module-libnl-0 phonon phonon-backend-gstreamer
  phonon-backend-gstreamer-common plasma-scriptengine-javascript
Use 'sudo apt autoremove' to remove them.
**The following packages have been kept back:
  colord**
The following packages will be upgraded:
  apport apport-gtk python3-apport python3-problem-report
4 to upgrade, 0 to newly install, 0 to remove and 1 not to upgrade.
Need to get 227 kB of archives.
After this operation, 0 B of additional disk space will be used.
Do you want to continue? [Y/n] y
Get:1 http://archive.ubuntu.com/ubuntu bionic-updates/main amd64 python3-problem-report all 2.20.9-0ubuntu7.21 [10.3 kB]
Get:2 http://archive.ubuntu.com/ubuntu bionic-updates/main amd64 python3-apport all 2.20.9-0ubuntu7.21 [82.3 kB]
Get:3 http://archive.ubuntu.com/ubuntu bionic-updates/main amd64 apport all 2.20.9-0ubuntu7.21 [125 kB]
Get:4 http://archive.ubuntu.com/ubuntu bionic-updates/main amd64 apport-gtk all 2.20.9-0ubuntu7.21 [9,700 B]
Fetched 227 kB in 1s (209 kB/s)        
(Reading database ... 323285 files and directories currently installed.)
Preparing to unpack .../python3-problem-report_2.20.9-0ubuntu7.21_all.deb ...
Unpacking python3-problem-report (2.20.9-0ubuntu7.21) over (2.20.9-0ubuntu7.20) ...
Preparing to unpack .../python3-apport_2.20.9-0ubuntu7.21_all.deb ...
Unpacking python3-apport (2.20.9-0ubuntu7.21) over (2.20.9-0ubuntu7.20) ...
Preparing to unpack .../apport_2.20.9-0ubuntu7.21_all.deb ...
Unpacking apport (2.20.9-0ubuntu7.21) over (2.20.9-0ubuntu7.20) ...
Preparing to unpack .../apport-gtk_2.20.9-0ubuntu7.21_all.deb ...
Unpacking apport-gtk (2.20.9-0ubuntu7.21) over (2.20.9-0ubuntu7.20) ...
Setting up python3-problem-report (2.20.9-0ubuntu7.21) ...
Setting up python3-apport (2.20.9-0ubuntu7.21) ...
Setting up apport (2.20.9-0ubuntu7.21) ...
apport-autoreport.service is a disabled or a static unit, not starting it.
Setting up apport-gtk (2.20.9-0ubuntu7.21) ...
Processing triggers for systemd (237-3ubuntu10.43) ...
Processing triggers for man-db (2.8.3-2ubuntu0.1) ...
Processing triggers for gnome-menus (3.13.3-11ubuntu1.1) ...
Processing triggers for hicolor-icon-theme (0.17-2) ...
Processing triggers for mime-support (3.60ubuntu1) ...
Processing triggers for ureadahead (0.100.0-21) ...
ureadahead will be reprofiled on next reboot
Processing triggers for desktop-file-utils (0.23-1ubuntu3.18.04.2) ...
Processing triggers for bamfdaemon (0.5.3+18.04.20180207.2-0ubuntu1) ...
Rebuilding /usr/share/applications/bamf-2.index...
laurence@LaurencePC1:~$ sudo do-release-upgrade
Checking for a new Ubuntu release
Please install all available updates for your release before upgrading.
laurence@LaurencePC1:~$ ^C
laurence@LaurencePC1:~$ 

Result of sudo apt upgrade colord

result of sudo apt upgrade colord

Result of grep -r deb /etc/apt/sources.list /etc/apt/sources.list.d/

C1:~$ grep -r deb /etc/apt/sources.list /etc/apt/sources.list.d/
/etc/apt/sources.list:# deb cdrom:[Ubuntu 16.04.1 LTS _Xenial Xerus_ - Release amd64 (20160719)]/ xenial main restricted
/etc/apt/sources.list:deb http://archive.ubuntu.com/ubuntu bionic main restricted
/etc/apt/sources.list:# deb-src http://gr.archive.ubuntu.com/ubuntu/ xenial main restricted
/etc/apt/sources.list:deb http://archive.ubuntu.com/ubuntu bionic-updates main restricted
/etc/apt/sources.list:# deb-src http://gr.archive.ubuntu.com/ubuntu/ xenial-updates main restricted
/etc/apt/sources.list:deb http://archive.ubuntu.com/ubuntu bionic universe
/etc/apt/sources.list:# deb-src http://gr.archive.ubuntu.com/ubuntu/ xenial universe
/etc/apt/sources.list:deb http://archive.ubuntu.com/ubuntu bionic-updates universe
/etc/apt/sources.list:# deb-src http://gr.archive.ubuntu.com/ubuntu/ xenial-updates universe
/etc/apt/sources.list:deb http://archive.ubuntu.com/ubuntu bionic multiverse
/etc/apt/sources.list:# deb-src http://gr.archive.ubuntu.com/ubuntu/ xenial multiverse
/etc/apt/sources.list:deb http://archive.ubuntu.com/ubuntu bionic-updates multiverse
/etc/apt/sources.list:# deb-src http://gr.archive.ubuntu.com/ubuntu/ xenial-updates multiverse
/etc/apt/sources.list:deb http://archive.ubuntu.com/ubuntu bionic-backports main restricted universe multiverse
/etc/apt/sources.list:# deb-src http://gr.archive.ubuntu.com/ubuntu/ xenial-backports main restricted universe multiverse
/etc/apt/sources.list:deb http://archive.canonical.com/ubuntu xenial partner
/etc/apt/sources.list:deb-src http://archive.canonical.com/ubuntu xenial partner
/etc/apt/sources.list:deb http://archive.ubuntu.com/ubuntu bionic-security main restricted
/etc/apt/sources.list:# deb-src http://security.ubuntu.com/ubuntu xenial-security main restricted
/etc/apt/sources.list:deb http://archive.ubuntu.com/ubuntu bionic-security universe
/etc/apt/sources.list:# deb-src http://security.ubuntu.com/ubuntu xenial-security universe
/etc/apt/sources.list:deb http://archive.ubuntu.com/ubuntu bionic-security multiverse
/etc/apt/sources.list:# deb-src http://security.ubuntu.com/ubuntu xenial-security multiverse
/etc/apt/sources.list:# deb-src http://packages.sil.org/ubuntu xenial main
/etc/apt/sources.list:deb http://activsoftware.co.uk/linux/repos/ubuntu bionic non-oss
/etc/apt/sources.list:# deb-src http://activsoftware.co.uk/linux/repos/ubuntu bionic non-oss
/etc/apt/sources.list:# deb-src http://activsoftware.co.uk/linux/repos/ubuntu bionic non-oss
/etc/apt/sources.list:deb http://activsoftware.co.uk/linux/repos/driver/ubuntu bionic oss non-oss
/etc/apt/sources.list:# deb-src http://activsoftware.co.uk/linux/repos/driver/ubuntu bionic oss non-oss
/etc/apt/sources.list:# deb-src http://activsoftware.co.uk/linux/repos/ubuntu bionic non-oss
/etc/apt/sources.list.d/packages-sil-org.list.save:# deb http://packages.sil.org/ubuntu bionic main # disabled on upgrade to bionic
/etc/apt/sources.list.d/google-chrome.list.save:deb [arch=amd64] http://dl.google.com/linux/chrome/deb/ stable main
/etc/apt/sources.list.d/eosrei-ubuntu-fonts-bionic.list.save:deb http://ppa.launchpad.net/eosrei/fonts/ubuntu bionic main
/etc/apt/sources.list.d/eosrei-ubuntu-fonts-bionic.list.save:# deb-src http://ppa.launchpad.net/eosrei/fonts/ubuntu bionic main
/etc/apt/sources.list.d/rolfbensch-ubuntu-sane-git-xenial.list.save:# deb http://ppa.launchpad.net/rolfbensch/sane-git/ubuntu bionic main # disabled on upgrade to bionic
/etc/apt/sources.list.d/rolfbensch-ubuntu-sane-git-xenial.list.save:# deb-src http://ppa.launchpad.net/rolfbensch/sane-git/ubuntu xenial main
/etc/apt/sources.list.d/packages-sil-org.list.distUpgrade:deb http://packages.sil.org/ubuntu xenial main
/etc/apt/sources.list.d/google-chrome.list.distUpgrade:deb [arch=amd64] http://dl.google.com/linux/chrome/deb/ stable main
/etc/apt/sources.list.d/packages-sil-org.list:# deb http://packages.sil.org/ubuntu bionic main # disabled on upgrade to bionic
/etc/apt/sources.list.d/skype-stable.list.save:deb [arch=amd64] https://repo.skype.com/deb stable main
/etc/apt/sources.list.d/rolfbensch-ubuntu-sane-git-xenial.list.distUpgrade:deb http://ppa.launchpad.net/rolfbensch/sane-git/ubuntu xenial main
/etc/apt/sources.list.d/rolfbensch-ubuntu-sane-git-xenial.list.distUpgrade:# deb-src http://ppa.launchpad.net/rolfbensch/sane-git/ubuntu xenial main
/etc/apt/sources.list.d/dropbox.list.distUpgrade:deb [arch=i386,amd64] http://linux.dropbox.com/ubuntu wily main
/etc/apt/sources.list.d/rolfbensch-ubuntu-sane-git-xenial.list:# deb http://ppa.launchpad.net/rolfbensch/sane-git/ubuntu bionic main # disabled on upgrade to bionic
/etc/apt/sources.list.d/rolfbensch-ubuntu-sane-git-xenial.list:# deb-src http://ppa.launchpad.net/rolfbensch/sane-git/ubuntu xenial main
/etc/apt/sources.list.d/skype-stable.list.distUpgrade:deb [arch=amd64] https://repo.skype.com/deb stable main
/etc/apt/sources.list.d/eosrei-ubuntu-fonts-bionic.list:deb http://ppa.launchpad.net/eosrei/fonts/ubuntu bionic main
/etc/apt/sources.list.d/eosrei-ubuntu-fonts-bionic.list:# deb-src http://ppa.launchpad.net/eosrei/fonts/ubuntu bionic main
/etc/apt/sources.list.d/skype-stable.list:deb [arch=amd64] https://repo.skype.com/deb stable main
/etc/apt/sources.list.d/keymanapp-ubuntu-keyman-bionic.list:deb http://ppa.launchpad.net/keymanapp/keyman/ubuntu bionic main
/etc/apt/sources.list.d/keymanapp-ubuntu-keyman-bionic.list:# deb-src http://ppa.launchpad.net/keymanapp/keyman/ubuntu bionic main
/etc/apt/sources.list.d/dropbox.list.save:# deb [arch=i386,amd64] http://linux.dropbox.com/ubuntu wily main # disabled on upgrade to bionic
/etc/apt/sources.list.d/dropbox.list:# deb [arch=i386,amd64] http://linux.dropbox.com/ubuntu wily main # disabled on upgrade to bionic
/etc/apt/sources.list.d/google-chrome.list:deb [arch=amd64] http://dl.google.com/linux/chrome/deb/ stable main
laurence@LaurencePC1:~$ 

Results after attempting to install simple-scan sane:

enter image description here

Results for apt-cache policy libsane-common:

Laurence@LaurencePC1:~$ apt-cache policy libsane-common
libsane-common:
  Installed: 1.0.27+git20181029-xenial0
  Candidate: 1.0.27+git20181029-xenial0
  Version table:
 *** 1.0.27+git20181029-xenial0 100
        100 /var/lib/dpkg/status
     1.0.27-1~experimental3ubuntu2.4 500
        500 http://archive.ubuntu.com/ubuntu bionic-updates/main amd64 Packages
        500 http://archive.ubuntu.com/ubuntu bionic-updates/main i386 Packages
     1.0.27-1~experimental3ubuntu2.3 500
        500 http://archive.ubuntu.com/ubuntu bionic-security/main amd64 Packages
        500 http://archive.ubuntu.com/ubuntu bionic-security/main i386 Packages
     1.0.27-1~experimental3ubuntu2 500
        500 http://archive.ubuntu.com/ubuntu bionic/main amd64 Packages
        500 http://archive.ubuntu.com/ubuntu bionic/main i386 Packages

Results for: sudo apt install --reinstall libsane-common=1.0.27-1~experimental3ubuntu2.4

[there is an error]

laurence@LaurencePC1:~$ sudo apt install --reinstall libsane-common=1.0.27-1~experimental3ubuntu2.4
[sudo] password for laurence: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following additional packages will be installed:
  colord libsane1
Suggested packages:
  colord-sensor-argyll hplip
Recommended packages:
  sane-utils
The following packages will be REMOVED
  libsane sane-utils
The following NEW packages will be installed
  libsane1
The following packages will be upgraded:
  colord
The following packages will be DOWNGRADED:
  libsane-common
1 to upgrade, 1 to newly install, 1 to downgrade, 2 to remove and 0 not to upgrade.
Need to get 2,556 kB of archives.
After this operation, 4,458 kB disk space will be freed.
Do you want to continue? [Y/n] y
Get:1 http://archive.ubuntu.com/ubuntu bionic-updates/main amd64 libsane1 amd64 1.0.27-1~experimental3ubuntu2.4 [2,088 kB]
Get:2 http://archive.ubuntu.com/ubuntu bionic-updates/main amd64 libsane-common all 1.0.27-1~experimental3ubuntu2.4 [273 kB]
Get:3 http://archive.ubuntu.com/ubuntu bionic/main amd64 colord amd64 1.3.3-2build1 [196 kB]
Fetched 2,556 kB in 2s (1,245 kB/s)
(Reading database ... 319188 files and directories currently installed.)
Removing sane-utils (1.0.27+git20181029-xenial0) ...
Selecting previously unselected package libsane1:amd64.
(Reading database ... 319176 files and directories currently installed.)
Preparing to unpack .../libsane1_1.0.27-1~experimental3ubuntu2.4_amd64.deb ...
Unpacking libsane1:amd64 (1.0.27-1~experimental3ubuntu2.4) ...
dpkg: error processing archive /var/cache/apt/archives/libsane1_1.0.27-1~experimental3ubuntu2.4_amd64.deb (--unpack):
 trying to overwrite '/usr/lib/x86_64-linux-gnu/libsane.so.1.0.27', which is also in package libsane:amd64 1.0.27+git20181029-xenial0
dpkg-deb: error: paste subprocess was killed by signal (Broken pipe)
Errors were encountered while processing:
 /var/cache/apt/archives/libsane1_1.0.27-1~experimental3ubuntu2.4_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
laurence@LaurencePC1:~$ sudo apt update && sudo apt -f install
Hit:1 http://dl.google.com/linux/chrome/deb stable InRelease
Hit:2 http://archive.ubuntu.com/ubuntu bionic InRelease                        
Hit:3 http://archive.canonical.com/ubuntu xenial InRelease                     
Hit:4 http://ppa.launchpad.net/eosrei/fonts/ubuntu bionic InRelease            
Get:5 http://archive.ubuntu.com/ubuntu bionic-updates InRelease [88.7 kB]      
Hit:6 http://activsoftware.co.uk/linux/repos/ubuntu bionic InRelease           
Hit:7 http://ppa.launchpad.net/keymanapp/keyman/ubuntu bionic InRelease        
Hit:8 http://activsoftware.co.uk/linux/repos/driver/ubuntu bionic InRelease    
Get:9 http://archive.ubuntu.com/ubuntu bionic-backports InRelease [74.6 kB]    
Get:10 http://archive.ubuntu.com/ubuntu bionic-security InRelease [88.7 kB]    
Hit:11 https://repo.skype.com/deb stable InRelease                             
Get:12 http://archive.ubuntu.com/ubuntu bionic-updates/main amd64 DEP-11 Metadata [294 kB]
Get:13 http://archive.ubuntu.com/ubuntu bionic-updates/universe amd64 DEP-11 Metadata [288 kB]
Get:14 http://archive.ubuntu.com/ubuntu bionic-updates/multiverse amd64 DEP-11 Metadata [2,468 B]
Get:15 http://archive.ubuntu.com/ubuntu bionic-backports/universe amd64 DEP-11 Metadata [9,288 B]
Get:16 http://archive.ubuntu.com/ubuntu bionic-security/main amd64 DEP-11 Metadata [49.0 kB]
Get:17 http://archive.ubuntu.com/ubuntu bionic-security/universe amd64 DEP-11 Metadata [59.5 kB]
Get:18 http://archive.ubuntu.com/ubuntu bionic-security/multiverse amd64 DEP-11 Metadata [2,464 B]
Fetched 958 kB in 3s (325 kB/s)                                                
Reading package lists... Done
Building dependency tree       
Reading state information... Done
1 package can be upgraded. Run 'apt list --upgradable' to see it.
N: Skipping acquire of configured file 'non-oss/binary-i386/Packages' as repository 'http://activsoftware.co.uk/linux/repos/ubuntu bionic InRelease' doesn't support architecture 'i386'
Reading package lists... Done
Building dependency tree       
Reading state information... Done
0 to upgrade, 0 to newly install, 0 to remove and 1 not to upgrade.
laurence@LaurencePC1:~$ sudo apt autoremove --purge
Reading package lists... Done
Building dependency tree       
Reading state information... Done
0 to upgrade, 0 to newly install, 0 to remove and 1 not to upgrade.
laurence@LaurencePC1:~$ sudo apt full-upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
The following packages have been kept back:
  colord
0 to upgrade, 0 to newly install, 0 to remove and 1 not to upgrade.
13
  • Do you have a version of colord that was installed from a ppa? If so, you should downgrade it to the repo version. If you edit your post and include the output of apt policy colord it will tell us if that is the issue. Dec 27 '20 at 3:58
  • Thanks for the edit. Why not just upgrade the package? Btw sudo is not required for the apt policy cmd. Dec 27 '20 at 13:29
  • what gives sudo apt upgrade colord ?
    – nobody
    Dec 27 '20 at 15:09
  • @OrganicMarble Do you mean upgrade colord? I'm not sure how I would do that. If you mean upgrade to 20.04, I am presently not able to do that when I use the command sudo do-release-upgrade because I am supposed to "install all available updates". The alternative seems to be to do a backup, delete colord (and thus delete the desktop), and hope the upgrade works. Dec 27 '20 at 16:08
  • 1
    yes as I thought. rolfbensch-ubuntu-sane-git-xenial.list It is alway a good idea to remove ppa's with ppa-purge before an distro-upgrade. apt-cache policy libsane-common please.
    – nobody
    Dec 27 '20 at 18:50
0

Personally, I don't see any problem with getting rid of the desktop during an upgrade. Most likely, a completely new desktop will come with the new release, and you must get rid of the old one to get the new one in place. Anyways, there's always a risk that comes with an upgrade, and you might end up screwing up your desktop if the upgrade does not finish successfully, but I'd say that is a fair risk to take. You always want to backup your OS before carrying on a system upgrade, so in case things go bad, you have a backup image to restore the system to.

I suggest that instead of doing the upgrade routine from a regular desktop session, you press Ctrl + Alt + F2 (or F3) to start a non-graphical session, and then carry on with the upgrade from there. That might reduce the risk of screwing up your upgrade if the graphical session crashes.

0
sudo apt install --reinstall libsane-common=1.0.27-1~experimental3ubuntu2.4

this will downgrade the package.

sudo apt update && sudo apt -f install

Then remove no longer required packages

sudo apt autoremove --purge

the update your bionic

sudo apt full-upgrade

then try again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.