0

I have Ubuntu (Version 20.10) on one disk, and Windows (10) on another physical disk in my dual boot system. I have been successfully reading from and writing to the Windows disk from within Linux for several months. This changed recently, possibly as a result of a driver update in Windows. I have disabled the Windows 'fast start up', and tried going into Linux after restarting, but no difference. The Windows disk is mounted, and the permissions information is the same for my Linux drive when I access it with Caja file manager. Running some commands in the terminal gave these results:

$ df df: /run/user/1000/doc: Operation not permitted Filesystem 1K-blocks Used Available Use% Mounted on tmpfs 804260 1712 802548 1% /run /dev/sda5 474840096 70993164 379656676 16% / tmpfs 4021292 0 4021292 0% /dev/shm tmpfs 5120 4 5116 1% /run/lock tmpfs 4096 0 4096 0% /sys/fs/cgroup /dev/sda2 524272 10968 513304 3% /boot/efi tmpfs 804256 148 804108 1% /run/user/1000 /dev/sda1 483975216 72036 459248968 1% /media/philip/UbuntuPhil /dev/nvme0n1p3 498799612 104113996 394685616 21% /media/philip/Windows

$ ntfsfix /dev/nvme0n1p3 Mounting volume... Error opening read-only '/dev/nvme0n1p3': Permission denied FAILED Attempting to correct errors... Error opening read-only '/dev/nvme0n1p3': Permission denied FAILED Failed to startup volume: Permission denied Error opening '/dev/nvme0n1p3': Read-only file system Volume is corrupt. You should run chkdsk. "Could not save the file “/media/philip/Windows/Do…ws updates, Dec 2020 .txt”.You are trying to save the file on a read-only disk. Please check that you typed the location correctly and try again.

$ fdisk /dev/nvme0n1p3 Welcome to fdisk (util-linux 2.36). Changes will remain in memory only, until you decide to write them. Be careful before using the write command. fdisk: cannot open /dev/nvme0n1p3: Permission denied

The problem seems to have arisen after these driver updates in Windows:

Flash BIOS Update for Lenovo V530s-07ICR, ThinkCentre M720e - 10 [64] - M30KT21A Successfully installed: 23/12/2020 8:25 am

Lenovo SSD Firmware Update Tool - 10 [64] - 40 Successfully installed: 16/12/2020 9:44 am

1
  • Nothing to report from me -- the situation remains the same. The disk is mounted and I can read from it, but I can't write to it. I would be very happy to run any sort of Linux command that would throw some light on what this on-going problem is. Feb 5, 2021 at 1:15

1 Answer 1

0

Thanks for all the help guys, but I managed to pull myself out of the problem anyhow. This website (after https://ubuntuhandbook.org/index.php/2016/01/mount-windows-10-in-ubuntu/) gave instructions that solved the problem. In a nutshell, using DISKS the trick was to disable “Automatic Mount Options” and add "remove_hiberfile" to the end of the text box.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.