I played Skyrim via Wine, then it started lagging so hard that I rebooted computer holding Power button. Then, when I turned it on, on a login page keyboard and mouse were working. I typed password, and after logging in noticed that keyboard and mouse are not working. I tried to reboot (same situation), tried recovery mode. Nothing worked. What I need to do? Ubuntu 18.04

  • how does this relate to Ubuntu? Please edit your question after reading How to Ask
    – 24601
    Dec 23, 2020 at 19:32
  • @User24601 I am using Ubuntu
    – Mouvre
    Dec 23, 2020 at 19:34
  • version? please edit your question rather than add comments.
    – 24601
    Dec 23, 2020 at 19:58

2 Answers 2


If you can type on the login screen, then there should be a way to workable shell.

This article has more on it.

From the description of the error, I would doublecheck for hardware problems, like e.g. a dying SSD. I would look for I/O errors in system logs.

If there are indeed signs of significant disk problems, then, before anything else, I would backup all important documents/files/etc from the disk, while being booted from a live USB.

After important files are backed up, I would also consider a filesystem check and possibly repair with fsck (on the unmounted / partition), again, from a live USB.

Then, regarding the keyboard / mouse:

Recently I have seen a few places that recommended

sudo apt-get install xserver-xorg-input-all


sudo apt-get install --reinstall xserver-xorg-input-all

read these: Keyboard and mouse unresponsive after suspend,

and the aforementioned article.

I have no personal experience with this procedure, just offering for consideration.

Finally, regarding "rebooted computer holding Power button", I recommend googling and learning how to reboot with the "REISUB" method. It's not always effective, but when it is, it's nicer on the (file)system.

  • Thanks for the answer, but how should I enter the commands if my keyboard and mouse are dead?
    – Mouvre
    Dec 24, 2020 at 10:14
  • Re-read the first two lines of my answer. Your inputs seem to not work after the graphical interface loaded; but before they do. Therefore, you should be able to navigate to a command line interface (not the graphical), where you can issue commands. This has more detailed info: askubuntu.com/a/859640/1157519
    – Levente
    Dec 24, 2020 at 10:32
  • 1
    Also this: wiki.ubuntu.com/RecoveryMode | Get to grub menu > pick advanced options for Ubuntu > pick recovery mode > pick 'drop to root shell' > follow the instructions, if any.
    – Levente
    Dec 24, 2020 at 10:44

To complete the answer provided by Levente, the following commands may come in handy:

1. Enable a disabled input device

  • Get the ids of the devices: xinput --list
  • Enable the device with id=n: xinput enable n

2. Remove/add modules to Linux kernel

  • Remove touchpad driver: modprobe -r psmouse
  • Add it again: modprobe psmouse
  • For keyboard, I think you must use atkbd instead of psmouse

NOTE that you need to run the commands as super user, I mean, sudo.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.