3

I am facing a very annoying behavior in Xubuntu, and I have been experiencing this since many versions (I think 16.04 is when I switched to Xubuntu) with many different computers so this problem has to be very common. Surprisingly I did not found questions/answers in Google about this so I ask here.

When I click/right-click the icons next to the clock in the panel the menu appears below the mouse pointer. Because of this, sometimes the option that appears just below the pointer is accidentally clicked (even by doing a single click) and this is very annoying. Usually this option is to close the corresponding app, but it can be anything. In this link you can see a video with the problem I have. I did not manage to make the apps to accidentally close in the video, but you see the "exit" button appears just below the pointer. Is there any easy solution for this? Like adding a constant offset to the menus, or adding a constant delay time of about 333 ms.

https://www.youtube.com/watch?v=sAIdvNg628c&feature=youtu.be

2
  • 1
    From my experience, the button-press-event triggers the menu to open, the button-release-event triggers the action. So if you press and hold the button, you should be still able to choose the desired action and then release the button to trigger it. If your mouse produces unwanted double clicks, this will be a hassle though.
    – mook765
    Mar 1 at 22:16
  • Yes, that is exactly what I am doing: Press and hold. But it is not the most natural.
    – user171780
    Mar 3 at 22:34
0

I had this problem when I tried to make the panel auto-hide until hovered. Had to give up on auto-hiding.

In panel preferences, set Automatically hide the panel to never, and uncheck Don't reserve space on borders.

I remember having to log out or reboot for this to fix the issue on older Xubuntu versions, but it doesn't seem to be necessary on 20.04.

0

To me the problem was happening when using an extra monitor, configured above (not at the side). The panel was at the bottom of the above monitor, where this issue was happening.

When clicking the option "Span monitors", the panel would go at the bottom of the lower monitor, and then the context menu (when clicking something, like the bluetooth icon) would appear correctly on top of the main menu bar.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.