I recently upgraded from Ubuntu 11.10 to 12.04 on my Dell Latitude D630C.

Now, when I want to shut down the system does shut down but then starts up again immediately. It's like it does a reboot instead of a shut down.

  • This also happens with the Toshiba Satellite C670D-108 but only when the mains power is active. To shutdown without restart I have to pull the power connector. – user57307 May 6 '12 at 13:20
  • @paulb1257 interesting! mine was the exact opposite. I have to plug in my power connector so my system would shutdown properly. If I shut it down while it's on battery, it just would do a restart. maybe the laptop_mode setting is somehow related to this issue. mine is ON(1) when on battery mode, while OFF(0) when on AC mode. – ultrajohn Sep 18 '12 at 12:36
  • no, i guess i'm wrong. i tried disabling laptop_mode on battery, but it still reboot when i shutdown. – ultrajohn Sep 18 '12 at 12:52

I have had exactly the same problem on my Acer V5-571G: the laptop shuts down, turns off its power LED, and then starts again after a few seconds.

The problem seems to arise from incorrect work of pm-utils (which are replacement for laptop-mode-tools). But if you write on into /sys/bus/*/devices/*/power/control, the kernel takes control over power management at the specified devices - and somehow this makes the hardware to shut down correctly.

So I have written a script:


case "$1" in
  stop) for i in /sys/bus/*/devices/*/power/control ; do echo on > $i ; done 

exit 0

and to make it being executed every time before shutdown I've placed it under name K32power-control-on into /etc/rc0.d directory (don't forget to make the script executable, sudo chmod +x K32power-control-on). After that the laptop shuts down ok.

I think that there are only a few buses/devices which need to have 'on' value written to their power/control, so the list of devices in the script can be restricted, but I just didn't investigate further.

| improve this answer | |

I had same problem in with my PC, but the first time it can be normally shutdown. Then, after a few days it can't be shutdown and always restart. After I had reinstalled the grub using boot-repair, because I formatted my windows, my PC could be shutdown normally as the first time.

You can obtain boot-repair here:


Hope this answer help you.

NB: I used boot-repair with live-usb and sorry if my english doesn't very good.

| improve this answer | |

I had the same issue with my new Acer Aspire v5 notebook. It has been solved by enabling laptop-mode by running

sudo apt-get install laptop-mode-tools

Hope it will help you.

| improve this answer | |
  • can you share you laptop_mode.conf? thanks! – ultrajohn Sep 18 '12 at 12:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.