11

I type a lot in Spanish and have a regular 105-key International Keyboard. So I have NO buttons for ñ or other accented letters. However, by setting the keyboard to "US Alternative International" I can easily type many accented letters. Just ' + e = é for instance. This is just like Windows. However, there I was able to type:

SHIFT + 1 = !
SHIFT + CTRL + 1 = ¡
SHIFT + / = ?
SHIFT + CTRL + / = ¿

Very convenient. But I have not been able to find a way to configure this in Ubuntu. I have to go to some site that has these symbols, and then copy-paste. Very inconvenient. Anybody any idea?

4 Answers 4

15

Keyboard layout: USA International (with dead keys)

¿ — Alt(R) + ?

¡ — Alt(R) + !

á — Alt(R) + a

Á — Alt(R) + Shift + a

é — Alt(R) + e

É — Alt(R) + Shift + e

í — Alt(R) + i

Í — Alt(R) + Shift + i

ñ — Alt(R) + n

Ñ — Alt(R) + Shift + n

ó — Alt(R) + o

Ó — Alt(R) + Shift + o

ú — Alt(R) + u

Ú — Alt(R) + Shift + u

ü — Alt(R) + y

Ü — Alt(R) + Shift + y

3
  • 2
    I tried this layout but it does not work. The [¿] symbol is shown on the same key as the [?] symbol, but ALT(R) + ? just does not work. Nothing shows up.
    – user6019
    Nov 13, 2010 at 16:05
  • 1
    Sorry, my bad... it did not show up in the text area where I could test characters, but after changing the settings system-wide I now have the ¿ available!
    – user6019
    Nov 13, 2010 at 16:09
  • I use Pop_OS! and this is the correct answer, but to find the right English International Keyboard I had to first select "English (United States)" Then a secondary menu came up and I had to choose the one with the title ¨English (US, intl., with dead keys)"
    – nephiw
    Jun 27, 2023 at 18:45
6

using Fourth Level Choosers

Press AltGr+Shift[held in]+ tap twice on 1 key to get ¡
Press AltGr+Shift[held in]+ tap twice on ? key to get ¿

or a bit harder why bother ::))

on Ubuntu press CTRL+SHIFT keep them in , press U and release U then following numbers and letters and release CTRL+SHIFT; then letter/symbol appears

IT IS ACTUALLY QUITE EASY !

¿ 00BF
¡ 00A1

and see here for more routes

3
  • On the harder solution, I think you need to release all the keys (CTRL, SHIFT and U) before typing in 00BF. And importantly you need to press return when you have finished typing in the 00BF. An underline will appear as you do all this to let you know that you are in "unicode composition" mode. Nov 26, 2015 at 9:45
  • Declan it works both ways held in and not .
    – shantiq
    Oct 6, 2019 at 9:25
  • At least on my computer, you don't actually have to press the "00": the sequence <ctrl>+<shift>+u, b, f, <space> types ¿
    – proto-n
    Feb 13, 2023 at 11:15
1

As for me in Ubuntu 16.04, I had to, first, configure properly the keyboard:

  1. Go to "Text Entry" app by typing its name in Unity. Then make sure "English (US)" is there in the list of input sources.
  2. Go to "Keyboard" app by typing its name in Unity. Then go to the Shortcuts tab, then choose "Typing" item on the left panel, then find the Compose Key row, and click on the right side where it says "Disabled" and change it to Right Alt.

From them on, these are the key shortcuts that work for me:

¿ — (holding) Alt(R) + ? + ?

(In my laptop keyboard I need to press Shift + / to actually type ?)

¡ — (holding) Alt(R) + ! + !

(In my laptop keyboard I need to press Shift + 1 to actually type !)

And for Spanish speakers, take this bonus:

ñ — (holding) Alt(R) + ~ + n

(In my laptop keyboard I need to press Shift + ` to actually type ~)

á — (holding) Alt(R) + ' + a

é — (holding) Alt(R) + ' + e

í — (holding) Alt(R) + ' + i

ó — (holding) Alt(R) + ' + o

ú — (holding) Alt(R) + ' + u

0

If you are using Ubuntu 10.10 and you are using US International (AltGr dead keys) from the keyboard layout switcher you can choose 'Show current layout' and look for the inverted question mark key. It should be something like using AltGr (right side alt) + ? and will produce ¿

2
  • It is indeed shown there, but even though I try AltGr + ?, nothing shows up!
    – user6019
    Nov 13, 2010 at 16:06
  • Again, my bad - it does not show up in the test box, but it does after changing the setting --- thanks!
    – user6019
    Nov 13, 2010 at 16:10

You must log in to answer this question.