0

I have already asked one question regarding issues in Ubuntu 20.04 with snap. I haven't really got any answer but a suggestion that the issues might be with the snap itself. I was trying to find out if we have an option to repair / reinstall the whole snap as if it was installed with fresh system but I couldn't find anything wile "googling" the problem.

Thanks

5
  • Your previous question seems to be about fontconfig errors. In general, read error cascades from top to bottom, and start looking for causes near the top. – user535733 Dec 18 '20 at 14:17
  • I googled fontconfig before and found a few answers. I tried plenty of commands: sudo dpkg --configure -a, sudo apt-get clean, sudo apt-get dist-upgrade, and sudo apt-get install --reinstall --purge fontconfig fontconfig-config but nothing worked. I am really out of options. I thought this could be related to snap itself but everyone suggests it is the system. I cannot figure out what else I could do. This is unfortunately beyond me. – Celdor Dec 18 '20 at 15:25
  • It's not beyond you, or anybody. This is learning. To me, it looks like re-installing snapd is the wrong track. I doubt that it will fix a fontconfig problem. But I've been wrong before. – user535733 Dec 18 '20 at 15:35
  • OK. I'll keep searching for fontconfig errors and try to find something. Thanks. – Celdor Dec 18 '20 at 15:54
  • I did comment on your previous question, asking for additional information. – user535733 Dec 18 '20 at 16:04
1

Try running sudo apt purge snapd && sudo apt install snapd to reinstall snap. I don't believe your issue is with snap, but if you wish to reinstall snap, this is how you do it.

2
  • Thanks. Do I have to umount any system or turn off any deamon before doing that? – Celdor Dec 18 '20 at 14:58
  • No you don't. After reinstalling, I recommend rebooting to make sure everything is back to normal. I'm always glad to help! – me is me Dec 18 '20 at 15:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.