I build custom ISO Ubuntu 20 according to this article. After the custom ISO is ready, I install the OS from it, and at first, the error appears: Check finished errors found in 1 files. Could you tell me how to find this error and fix it? I already checked md5sum, I read about it.

  • You've tagged 20.04, but refer to Ubuntu 20 (which doesn't exist, but is closest to Ubuntu Core 20 which is a different product to 20.04). The wiki page refers to md5sums, which are deprecated & replaced by sha256sums. (you should have noticed that at the download page cdimage.ubuntu.com/ubuntu/releases/20.04/release) Note: this is opinion only, if I knew it was fact, I'd correct the wikipage which I believe to be outdated.
    – guiverc
    Dec 18, 2020 at 11:46
  • If errors are reported and you need help solving the problem, it might be useful to include actionable error messages. There are a million reasons for why something might not be working as expected.
    – user1091774
    Dec 26, 2020 at 4:40
  • I have been seeing the same error with the xubuntu-20.04.1-desktop-amd64.iso image. There is no actionable error message. This is a check done when you start the boot process - it reports the error exactly as described (Check finished errors found in 1 files! You might encounter errors.). Otherwise, everything still seems to work. To be clear: I checked the SHA256 checksum, reburned the image to my USB, burned it again with Startup Disk Creator, tried again with dd, tried a different USB, downloaded from a different mirror, downloaded a torrent, and then tried all those things again...
    – topsail
    Dec 27, 2020 at 2:22
  • a related issue (and link to a bug report) is here: answers.launchpad.net/ubuntu/+question/691933
    – topsail
    Dec 28, 2020 at 18:03

3 Answers 3


It is mentioned in this bug report that "Windows write System Volume Information on any filesystem it can understand (EFI boot partition in this case) which causes the checksum to fail.". This matches my experience, where the error was reported, repeatably, if the USB stick is inserted into a live Windows system between the time it was created and when it is booted.

Looking closer, a folder System Volume Information is added to the small EFI (Fat-12/16/32) partition.

EFI partition in context

EFI partition contents

Advice: Avoid inserting live USB while Windows is running.

  • FYI, I successfully created a bootable USB thumb drive (no errors when Windows not involved) using the "Restore Disk Image" feature of 'gnome-disk-utility'. Jan 6, 2022 at 1:05

Based on what I can discover from looking at this bug report and discussion (Check error with 20.04-desktop ISO) it appears this is just a built-in limitation of the file checking where the efi.img file is modified when it is loaded and that really means it can't be verified. I would advise go ahead and ignore this error! That is what I have done with my Xubuntu installation and I have had no problems at all (since then I have also noticed this error when installing Ubuntu Mate and I also ignored it in that case as well!)

  1. Press ctrl + c to stop checking or skip this process.
  2. Use "Try Ubuntu".
  3. Then, Install Ubuntu 20.04 lts from inside "Try Ubuntu". Note: Don't remove your boot-able Pen-drive until it saying to remove it.

I faced same issue like yours and above was helpful.

  • you could format your buttons better with <kbd> ... </kbd>. May 21, 2021 at 23:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.