0

I've just installed Kubuntu 20.04 and I'm trying to use my speakers, although the headphones jack is connected.

When I connect the headphones, I can see in pavucontrol-qt "analogue headphones" as the output device and when i change it to line-out, the sound dissapears.

But when I unplug my headphones, the output device changes automatically to line-out and sound gets out perfectly from the speakers.

I've tried:

  • Enabling "simoultaneous output" in paprefs but it doesnt work.

  • Changing the Mute in alsamixer

With this one, I saw that the headphones are mutted with line-out. When I unmute them, they sound, but still not the speakers.

I made the speakers sound disabling auto-Mute, but now I can't hear the headphones, although they are connected.

There is another problem: I cannot route applications between headphones and line-out, there are just two options: analog stereo internal audio and simultaneous output to analog stereo internal audio (with this one is the same problem: either speakers with disabling auto-mute, or headphones).

If it is needed: a bild of alsamixer

and a bild of output devices:
and a bild of output devices

In "audio interno estéreo analógico" ports are the headphones or line-out options.

Motherboard: GA970A-DS3P (Rev.2.x) Audio Realtek ALC887 codec NOTE: I'm using just Realtek audio, I don't use HDMI audio

1 Answer 1

1

Finally something worked: in alsamixer I enabled Loopback and disabled Auto-Mute.

I also manually configured them in alsamixer and pavucontrol:

Go to output devices in pavucontrol, set line-out as port and set the headphones volume to "0", then set headphones as port and set "front" on "0" (without muting: when I mute it, all the sound mutes)

Now the routing is working well but I need to search for how to route a single app because I cannot see the option in pavucontrol or system audio.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.