1

The Problem

All the systems specs can be found at the bottom.

Ubuntu 20.04 with nvidia-driver-* is capped at 60 FPS on a 144hz screen. I'm aware this happens in a multi-screen setup with one screen being 60hz, but the problem persists even when there's only the primary 144hz screen in use.

The problem goes away if I switch to the iGPU with xserver-xorg-video-nouveau drivers. Everything is butter smooth, as it should be. Yet when I switch back to dGPU and nvidia-driver-* drivers, the issue returns.

Some symptoms

  1. For a brief period of time, the issue went away. This happened after one of the nvidia-* updates, though I can't say exactly which one. For a while, everything worked as it should, but after the next update, the issue returned. I believe it was the update from 455.38 to 455.45 that broke it again. Going back to the previous driver version (downgrading from 455.45 to 455.38) did not help. I have also tried purging all the nvidia drivers and reinstalling them and using nvidia-driver-450.

  2. The mouse cursor can be rendered at 144 FPS. By default it's also capped, but if I change the refresh rate in display settings back and forth, it temporarily becomes 144 FPS. It will reset back to 60 FPS after some time, and I'd have to change the setting back and forth again for it to resume being smooth.

  3. xrandr --output eDP-1-1 --mode 1920x1080 --rate 144 did not help.

System specs

System:
  Kernel: 5.4.0-58-generic x86_64 bits: 64 compiler: gcc v: 9.3.0 
  Desktop: Gnome 3.36.4 Distro: Ubuntu 20.04.1 LTS (Focal Fossa) 
Machine:
  Type: Laptop System: Schenker product: XMG FUSION 15 (XFU15L19) 
CPU:
  Model: Intel Core i7-9750H 
Graphics:
  Device-1: Intel UHD Graphics 630 driver: i915 v: kernel bus ID: 00:02.0 
  Device-2: NVIDIA TU106M [GeForce RTX 2070 Mobile] vendor: Intel 
  driver: nvidia v: 455.45.01 bus ID: 01:00.0 
  Display: server: X.Org 1.20.8 driver: modesetting,nvidia 
  unloaded: fbdev,nouveau,vesa resolution: 1920x1080~144Hz 
  OpenGL: renderer: GeForce RTX 2070 with Max-Q Design/PCIe/SSE2 
  v: 4.6.0 NVIDIA 455.45.01 direct render: Yes 
Info:
  Memory: 62.66 GiB
0

In nvidia-settings, untick 'allow flipping''.

1
  • 1
    Might be, but could you elaborate why this might help the OP?
    – kanehekili
    May 8 at 22:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.