I installed Ubuntu (Ubuntu 20.04.1 LTS) on my Macbook and I am using it with an external Apple keyboard.

My problem is that the Left Shift is not working as I expect it. .E.g. to write capital letters, to use it with combination with arrows to select text etc.

Instead it activates shortcuts, like Left Shift + s is toggling all the opened apps, Left Shift + arrows is minimizing and moving the current window to left or right etc.

Currently the normal for me behavior (of the left shift) is working on the right shift - I would like to use the left and right without these shortcuts that I don't even use and in worst case just move this behavior to the right shift.

If someone could help me with this I would be very grateful since I searched for this for quite a while and the solutions I found were not 100% satisfactory.

1 Answer 1

sudo dpkg-reconfigure keyboard-configuration  

Choose the 104-key layout.

sudo service keyboard-setup restart
  • thanks for the answer Edmund, but it is still not working. do you mean Generic 104-key PC ? also is it possible that it is conflicting with "Tweak advanced GNOME 3 settings"? Dec 17, 2020 at 10:53

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .