0

I am trying to set up an external monitor as an extended display for my laptop. [Ryzen 4800H + GTX1650]

When booting up, the monitor briefly shows the boot screen for a second but then switches to the “no signal” message.

Even though the settings detects the external monitor, nothing pops up on it when I am trying to change the display settings. When I click on “joint display” or “mirror” and hit “apply” to save the changes in settings, it just resets to single screen. No change observed whatsoever.

I have checked for connection issues. That is not the problem. Also, works flawlessly with Windows.

0

you can use this commandes :

sudo xrandr -q : to show all external port for display and resolution screen

sudo xrandr --addmode VGA-1 1360x768 : to set configuration for second display

4
  • Hello! Thank you for the response! I tried this to add an sudo xrandr --addmode HDMI-1 1920x1080 and got a BadMatch error. – Kadams Dec 18 '20 at 14:59
  • What is the output for sudo xrandr -q?? – Mokhless Hachicha Dec 18 '20 at 15:15
  • Screen 0: minimum 320 x 200, current 1920 x 1080, maximum 16384 x 16384 eDP connected 1920x1080+0+0 (normal left inverted right x axis y axis) 344mm x 194mm 1920x1080 60.02*+ 39.98 HDMI-1-0 connected primary 1920x1080 60.00 + 74.97 59.94 50.00 1680x1050 59.95 1600x900 60.00 1440x900 59.89 1280x1024 75.02 70.00 60.02 1280x800 59.81 1280x720 60.00 59.94 50.00 Removed some lower resolutions for character limit. – Kadams Dec 18 '20 at 18:27
  • you have to type this command: sudo xrandr --addmode HDMI-1-0 1920x1080 – Mokhless Hachicha Dec 19 '20 at 19:32
0

I had some problems (Ubuntu 20.10 Gnome), and solve this problem by installing a proprietary nvidia driver and in "NVIDIA X Server Settings" switch "PRIME Profile" to "Performance mode". After reboot external monitor earned.

1
  • Could you please edit your answer and also add the commands / steps you implemented when installing those drivers (including their names)? This would really help future users stumbling upon this answer. – Pizza Apr 9 at 7:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.