1

I have HP Envy 15-j171nr Laptop. I have installed Ubuntu 18.04.3 LTS and it auto installed most of the driver except the Bluetooth. From the hp site I can only discovered that it has Broadcom Bluetooth driver I don't know what's the issue here. I tried googling but there is some solution that is beyond my understanding.

I have tried this though it won't do anything major:

sudo service bluetooth start

EDIT:

Here's the output for lspci -knn | grep Net -A3; lsusb

07:00.0 Network controller [0280]: Ralink corp. RT3290 Wireless 802.11n 1T/1R PCIe [1814:3290]
Subsystem: Hewlett-Packard Company Ralink RT3290LE 802.11bgn 1x1 Wi-Fi and Bluetooth 4.0 Combo Adapter [103c:18ec]
Kernel driver in use: rt2800pci
Kernel modules: rt2800pci
Bus 001 Device 002: ID 8087:8000 Intel Corp. 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 002 Device 003: ID 04f2:b40d Chicony Electronics Co., Ltd 
Bus 002 Device 004: ID 138a:0050 Validity Sensors, Inc. Swipe Fingerprint Sensor
Bus 002 Device 002: ID 046d:c534 Logitech, Inc. Unifying Receiver
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Here's the output for sudo /etc/init.d/bluetooth status after sudo /etc/init.d/bluetooth start:

● bluetooth.service - Bluetooth service
   Loaded: loaded (/lib/systemd/system/bluetooth.service; enabled; vendor preset: enabled)
   Active: inactive (dead)
     Docs: man:bluetoothd(8)
3
  • Please edit your question and add output of lspci -knn | grep Net -A3; lsusb terminal command. – Pilot6 Dec 16 '20 at 18:35
  • @Pilot6 updated the required output. – mauliksompura Dec 16 '20 at 18:41
  • 1
    I am afraid it is hard to solve with this adapter. You can google about it. It is not Broadcom. It is a Ralink. – Pilot6 Dec 16 '20 at 18:54
0
sudo add-apt-repository ppa:blaze/rtbth-dkms

sudo apt update

sudo apt install rtbth-dkms

sudo vim /etc/rc.local

Add the command modprobe rtbth &> /dev/null right before "exit 0" and save.

sudo chmod 777 /etc/rc.local
sudo apt install blueman

Reboot.

11
  • Tried this. still not found. Getting this error: Connection to Bluez failed when I open bluetooth manager. – mauliksompura Dec 17 '20 at 10:24
  • sudo /etc/init.d/bluetooth start – Edmund Dec 17 '20 at 11:44
  • tried this and added status in question please check. – mauliksompura Dec 22 '20 at 7:44
  • Now try systemctl start bluetooth – Edmund Dec 22 '20 at 8:54
  • still the same status. – mauliksompura Dec 22 '20 at 8:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.