2

I am unable to set the HDMI output of my NVidia video card to anything other than 640x480.

My system was working fine until about a week ago. At that time, I booted back into Linux from windows after a gaming session and found that my boot process would get hung up before I could even load the kernel (i.e. Grub followed by black screen). From past experience, I knew there were two things that I should try when this happens: 1) Rebuild my initramfs and 2) Switch my nvidia driver to nouveau and then back to the non-free one. I did that, it booted, but now I can't use my nvidia card for anything but basic VGA (in linux - in windows, it works perfectly).

I tried downgrading the nvidia driver version to 450 (was 455), but that didn't help at all.

After lots of digging and trying things out, I started issuing commands with xrandr and go this error if I tried to set the resolution to anything higher than 640x480:

xrandr --output HDMI-1-0 --mode 1280x1024
X Error of failed request:  BadMatch (invalid parameter attributes)
  Major opcode of failed request:  140 (RANDR)
  Minor opcode of failed request:  29 (RRSetPanning)
  Serial number of failed request:  64
  Current serial number in output stream:  64

xrandr -q:

Screen 0: minimum 320 x 200, current 2960 x 1050, maximum 8192 x 8192
HDMI-1 connected 1680x1050+0+0 (normal left inverted right x axis y axis) 474mm x 296mm
   1680x1050     59.97*+  59.95    59.88  
   1600x1024     60.17  
   1600x1000     60.01  
   1400x1050     74.76    70.00    59.98  
   1600x900      59.95    59.82  
   1280x1024     75.02    72.05    60.02  
   1440x900      74.98    59.89    59.90  
   1400x900      59.96    59.88  
   1280x960      60.00  
   1440x810      59.97  
   1368x768      59.88    59.85  
   1360x768      59.80    59.96  
   1280x800      59.99    59.97    59.81    59.91  
   1152x864      75.00    75.00    70.00    60.00  
   1280x720      60.00    59.99    59.86    59.74  
   1024x768      75.05    60.04    75.03    70.07    60.00  
   960x720       75.00    60.00  
   928x696       75.00    60.05  
   896x672       75.05    60.01  
   1024x576      59.95    59.96    59.90    59.82  
   960x600       59.93    60.00  
   832x624       74.55  
   960x540       59.96    59.99    59.63    59.82  
   800x600       75.00    70.00    65.00    60.00    72.19    75.00    60.32    56.25  
   840x525       74.96    69.88    60.01    59.88  
   864x486       59.92    59.57  
   800x512       60.17  
   700x525       74.76    70.06    59.98  
   800x450       59.95    59.82  
   640x512       75.02    60.02  
   720x450       59.89  
   700x450       59.96    59.88  
   640x480       60.00    75.00    72.81    75.00    66.67    59.94  
   720x405       59.51    58.99  
   720x400       70.08  
   684x384       59.88    59.85  
   680x384       59.80    59.96  
   640x400       59.88    59.98  
   576x432       75.00    75.00    70.00    60.06  
   640x360       59.86    59.83    59.84    59.32  
   512x384       75.03    70.07    60.00  
   512x288       60.00    59.92  
   416x312       74.66  
   480x270       59.63    59.82  
   400x300       72.19    75.12    60.32    56.34  
   432x243       59.92    59.57  
   320x240       72.81    75.00    60.05  
   360x202       59.51    59.13  
   320x180       59.84    59.32  
DVI-I-1 disconnected (normal left inverted right x axis y axis)
VGA-1 disconnected (normal left inverted right x axis y axis)
DP-1-0 disconnected
DP-1-1 disconnected
DP-1-2 disconnected
DP-1-3 disconnected
HDMI-1-0 connected 640x480+1680+0 1600mm x 900mm panning 1280x1050+1680+0 tracking 2960x1050+0+0 border 0/0/0/0
   3840x2160     60.00 +
   2880x480      59.94  
   1920x1080     60.00    59.94    29.97    23.98  
   1440x480      59.94  
   1360x768      60.02  
   1280x1024     60.02  
   1280x720      59.94  
   1152x864      60.00  
   1024x768      60.00  
   800x600       60.32  
   720x480       59.94  
   640x480       59.95*   59.93    59.94  
DP-1-4 disconnected
DP-1-5 disconnected
  1280x1024 (0x53) 108.000MHz +HSync +VSync
        h: width  1280 start 1328 end 1440 total 1688 skew    0 clock  63.98KHz
        v: height 1024 start 1025 end 1028 total 1066           clock  60.02Hz
  1152x864 (0x66) 81.620MHz -HSync +VSync
        h: width  1152 start 1216 end 1336 total 1520 skew    0 clock  53.70KHz
        v: height  864 start  865 end  868 total  895           clock  60.00Hz
  1024x768 (0x6f) 65.000MHz -HSync -VSync
        h: width  1024 start 1048 end 1184 total 1344 skew    0 clock  48.36KHz
        v: height  768 start  771 end  777 total  806           clock  60.00Hz
  800x600 (0x87) 40.000MHz +HSync +VSync
        h: width   800 start  840 end  968 total 1056 skew    0 clock  37.88KHz
        v: height  600 start  601 end  605 total  628           clock  60.32Hz
  640x480 (0x9e) 25.175MHz -HSync -VSync
        h: width   640 start  656 end  752 total  800 skew    0 clock  31.47KHz
        v: height  480 start  490 end  492 total  525           clock  59.94Hz

Xorg.0.log

I have a second video card, a radeon device, which works just fine.

System:

  • Ryzen 5, no integrated graphics
  • B450 Tomahawk Max motherboard
  • ADATA SX8100 512 GB SSD
  • Nvidia GeForce 1660 main GPU
  • Radeon HD 5450 secondary GPU
  • Dual boot Ubuntu 20.04 and windows 10
  • UEFI firmware
  • No overclocking or other tweaks
  • no xorg.conf, using auto-config
1
  • bump nothing? can anyone even suggest how I would troubleshoot this further? – rothloup Dec 17 '20 at 5:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.