I tried upgrading from 11.10 to 12.04. It got to the point of installing packages then I stepped away. When I got back the screen was black (possibly due to the screen saver). I left it for about 8 hours and there was no change. I then power-cycled and now it won't boot to a login screen. I tried hitting <Esc> repeatedly while powering up (to get to the Grub menu) but that has no effect.

What should I do now?


I can see the files on the hard disk once I boot from a Live CD. I saw some stuff online about using chroot and dpkg to continue an aborted upgrade from the command line. Is there any comprehensive guide on this?

  • Try booting into live and see if all the files and folders are fine on the partitions. If so, then probably you have a messed up GRUB. May 2, 2012 at 12:08
  • So assuming the files are there, what do I do next? I want to finish the upgrade.
    – SpashHit
    May 2, 2012 at 12:17
  • 2
    I found an adequate guide at: superuser.com/questions/195786/…
    – SpashHit
    May 3, 2012 at 3:18

3 Answers 3


The original poster here, SplashHit, indicated in a comment that this question on SuperUser answered the question.

  • In that question, the OP followed this "guide" posted on Launchpad (which is actually the original version of this bug report by TJ).

  • rumtscho, the OP of that SuperUser question, had attempted to chroot into the installed system from a live CD system and run dpkg --configure -a, but there were lots of Permission denied error messages.

  • The accepted answer (by Darth Android) was that the OP needed to mount the /proc and /dev filesystems in the chroot before running dpkg ....

It's unclear from SplashHit (the original poster here)'s comment whether the Launchpad "guide" was sufficient to solve this problem here, or if the answer to that question was also necessary.

In any case, it appears that this question is now effectively answered for the OP (and abandoned).

@SplashHit, if I am mistaken and you still need help with this problem, please let us know (you can post a comment here, and of course if there is additional information then you can add that to your question).


Try holding down Shift to get to the GRUB2 menu. If that works, see if you can boot any of the options. (You can then provide more information in your question.)

If that doesn't work, or you do get a GRUB2 menu but you can't boot into Ubuntu, try reinstalling the GRUB2 boot loader to your Master Boot Record (MBR), using any of these methods.

Once you've booted into Ubuntu, you can attempt to repair and finish the upgrade by running sudo apt-get dist-upgrade.


About using chroot, you can take a look at this Gentoo guide:

It says how you can reinstall grub, but you can run dpkg --configure -a instead of grub2-install.

The main idea of the chroot approach is to mount your original / partition on the live CD filesystem, probably on /mnt/mysystem, then chroot to /mnt/mysystem. After chrooting, your / will be actually /mnt/mysystem, your original /. It's like you CHanged your ROOT.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .