5

Ever since a recent update of Ubuntu (through the standard update prompt - not a major version update), the "cable snake" symbol keeps appearing in the taskbar every few seconds. i.e. the symbol with the three dots below:

cable with three dots

Why does it now keep appearing and how do I stop it? I would like to make it stop constantly appearing and disappearing because it is distracting.

OS: Ubuntu 18.04.5 LTS
Package: bolt (0.5-0ubuntu0.18.04.1). system daemon to manage thunderbolt 3 devices.

Related question: What does the indicator icon with three dots over a power plug mean in Ubuntu 20.04?

Additional info: It appears that this bug has been fixed for Focal Fossa. However, I am running Bionic Beaver and have a good reason not to upgrade at the moment.

4
+125

A blown up image shows the cable snake on the left:

boltd cable snake

From the author's blog:

GNOME Shell

The GNOME shell bits to enable Thunderbolt 3 support were merged some time ago and made it into 3.28. This means that the GNOME shell will act as authorization agent and will automatically authorize new thunderbolt 3 devices — if the user has administrator rights, is currently logged in and the session is unlocked. It will also show a little indicator (called the cable_snake by some) in the status indicator section while devices are being authorized because the whole authorization dance can take quite a while.


Correspondence from developer

I emailed the developer and this is our conversation:

There are users annoyed with Cable_Snake icon making icons shift left and right in the application indicator top bar. Is there a way to disable the icon but keep boltd running?

This was introduced via a change in the kernel/udev, but a work-around laded in bolt 0.9: https://gitlab.freedesktop.org/bolt/bolt/-/issues/156

There is an ubuntu bug open: https://bugs.launchpad.net/ubuntu/+source/bolt/+bug/1892657

Is there a way to disable the icon but keep boltd running?

Currently not, GNOME Shell is hardwired to react to boltd's probing setting. Best way is to update bolt.

Follow the author's blog for updates.


Some ideas of my own

I use the Unity interface where application indicators are right justified on the top bar so new apps opening and closing on the left are preferred and not a disadvantage.

For Gnome Users to prevent icons jumping back and forth the only band-aid I can think of is moving all icons to the right side. This can probably be achieved here:

If this works, then when the boltctl icon appears and disappears on the left side nothing "jumps around".


I've emailed the developer again on December 24, 2020 with a link to OP's problem and asked these questions:

  • A) Is there an update to correct the problem?
  • B) Is it possible to define a new cable snake icon which is 0x0 pixels such that even if it still reappears every few seconds the effect is invisible?
3
  • Thank you for highlighting your post from the related question. In addition to this work-around for making it appear on the left, you can also disable the whole system menu with the dash-to-panel extension. This gets rid of some useful functionality but it can be helpful if it is really getting on your nerves – Bart Dec 23 '20 at 14:00
  • 1
    @Bart I've just emailed the developer asking about a solution to your problem. – WinEunuuchs2Unix Dec 24 '20 at 15:15
  • 1
    Thank you for contacting the developer again. It seems like they managed to fix this for Focal Fossa, so it's shouldn't be too difficult to allow Bionic Beaver users to download the fix too... – Bart Dec 28 '20 at 7:53
1

Did you try any of the solutions/workarounds proposed?

  1. Adding a dock to the blacklist of tlp. Do you have a docking station?
  2. Install the Panel Indicators extension that moves the power/network icons to the status area... Extension 3022 seems removed as of now
4
  • Option 1, I don't know how to do what they describe. Option 2, I don't know what this extension does exactly. What is the "status area"? What is the main difference afterwards? Their screenshot looks like a normal task bar to me. – Bart Dec 23 '20 at 14:05
  • @Bart - Please see update – sancho.s ReinstateMonicaCellio Dec 23 '20 at 20:27
  • Thank you for following up on this. Yes, I have a docking station. I have tlp but not powertop (based on the command 'which'). I just don't know how to add "my dock to the blacklist of tlp" and how to test this. – Bart Dec 28 '20 at 7:51
  • @Bart - Perhaps this helps askubuntu.com/a/370406/226614 A quick "ubuntu blacklist tlp" search can probably lead you easily to this target (although I am not sure it solves your problem). – sancho.s ReinstateMonicaCellio Dec 28 '20 at 11:00
1

To disable specific tray icons, there is a handy GNOME extension: icon-hider.
Make sure you have GNOME Tweaks installed, if you don't, run sudo apt install gnome-tweaks. You can access the extension from the gnome-tweaks app after you install it, and disable specific tray icons!
Note: The extension is old and may not work on newer versions of GNOME.

1
  • Thank you for your suggestion. I have tried the icon hider, but unfortunately it did not solve my problem. i.e. the cable snake keeps appearing and I could not disable it. – Bart Dec 23 '20 at 13:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.