There does not seem to be a "Release" file at http://old-releases.ubuntu.com/ubuntu/dists/eoan/

I was wondering why apt was throwing me errors when I changed sources to "old-releases". I can see all previous releases having release files, but not eoan.

And no it is not available anymore at archive.ubuntu.com

  • I don't have an eoan system anymore to grab error message, but I'd likely mention on IRC, it maybe related to vorlon's recent post with issues noticed on 16.04.7, 18.04.5 etc release as issues were discovered... It'll likely need a bug report (ticket) raised. A different issue impedes me chasing this up (hirsute issue) currently
    – guiverc
    Dec 11, 2020 at 0:01
  • I believe this was also asked at ubuntuforums.org/showthread.php?t=2455026 (or it was another post; two ~equal enquiries have been made today on askubuntu). I've made an enquiry (hours ago) on #ubuntu-website, but I don't expect a quick response. I'd suggest upgrade via re-install, ie. something-else, select existing partitions, and don't format any. It'll note your packages, erase system directories, install, then add back additional packages if available on new release, ask to reboot. It's great on desktop, servers store conf files in system dirs so some recovery is required
    – guiverc
    Dec 11, 2020 at 6:31

2 Answers 2


As of about 7:15 am CST (UTC-6) on 2020-12-14, the Release file exists on http://old-releases.ubuntu.com/ubuntu/dists/eoan/.

  • Correct me if i'm wrong but all this is going to do is stop the error message from showing up its not actually going to update anything.
    – DaImTo
    Jan 4, 2021 at 6:29
  • @DaImTo yes, after updating sources.list to point at the old releases subdomain, you would have to do your regular apt update & apt dist-upgrade. And after that, you can follow procedure to switch your ubuntu to a newer version. Preferably LTS.
    – pwned
    Mar 9, 2021 at 8:21
  • ok and how to use the release file? I'm stuck with 19.10 and no way to upgrade
    – Jus12
    Jul 28, 2021 at 16:18

I have the same issue, can't upgrade because of this.

I solved my problem by going to the list of Ubuntu mirrors at https://launchpad.net/ubuntu/+archivemirrors

And going through them randomly, until I stumbled upon one that still had eoan: http://de.mirrors.clouvider.net/ubuntu/dists/

I added that mirror instead of old-releases.ubuntu.com, and apt update worked.

Of course, this will probably not last, so I will upgrade to a supported version ASAP.


Not the answer you're looking for? Browse other questions tagged .