5

I set up a dual-booted Ubuntu 20.04 for Asus ZenBook UX393EA, which has an integrated graphics card 'Intel(R) Iris(R) Xe Graphics'. However I find llvmpipe (LLVM 11.0.0, 256 bits) is used but not the integrated graphics card.

I believe some other issues are due to this, such as:

  • xrandr failed to get size of gamma for output default
  • the screen resolution can only be set to one value
  • no control bar for screen brightness

Here are some info:

  • linux kernel
➜  ~ uname -r 
5.4.0-56-generic
  • lspci
➜  ~ lspci -nnk | grep -iA2 VGA   
0000:00:02.0 VGA compatible controller [0300]: Intel Corporation Device [8086:9a49] (rev 01)
    DeviceName: VGA
    Subsystem: ASUSTeK Computer Inc. Device [1043:13e2]
    Kernel modules: i915
  • inxi

(as you can see, the driver for Intel graphics is not loaded)

➜  ~ inxi -G  
Graphics:  Device-1: Intel driver: N/A 
           Device-2: IMC Networks USB2.0 HD IR UVC WebCam type: USB driver: uvcvideo 
           Display: x11 server: X.Org 1.20.8 driver: fbdev unloaded: modesetting resolution: 3300x2200~90Hz 
           OpenGL: renderer: llvmpipe (LLVM 11.0.0 256 bits) v: 4.5 Mesa 21.0.0-devel (git-3f0da80 2020-12-10 focal-oibaf-ppa)
  • glxinfo
➜  ~ glxinfo -B
name of display: :1
display: :1  screen: 0
direct rendering: Yes
Extended renderer info (GLX_MESA_query_renderer):
    Vendor: Mesa/X.org (0xffffffff)
    Device: llvmpipe (LLVM 11.0.0, 256 bits) (0xffffffff)
    Version: 21.0.0
    Accelerated: no
    Video memory: 15694MB
    Unified memory: no
    Preferred profile: core (0x1)
    Max core profile version: 4.5
    Max compat profile version: 3.1
    Max GLES1 profile version: 1.1
    Max GLES[23] profile version: 3.2
OpenGL vendor string: Mesa/X.org
OpenGL renderer string: llvmpipe (LLVM 11.0.0, 256 bits)
OpenGL core profile version string: 4.5 (Core Profile) Mesa 21.0.0-devel (git-3f0da80 2020-12-10 focal-oibaf-ppa)
OpenGL core profile shading language version string: 4.50
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile

OpenGL version string: 3.1 Mesa 21.0.0-devel (git-3f0da80 2020-12-10 focal-oibaf-ppa)
OpenGL shading language version string: 1.40
OpenGL context flags: (none)

OpenGL ES profile version string: OpenGL ES 3.2 Mesa 21.0.0-devel (git-3f0da80 2020-12-10 focal-oibaf-ppa)
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.20
  • lshw
➜  ~ sudo lshw -c video
  *-display UNCLAIMED       
       description: VGA compatible controller
       product: Intel Corporation
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 01
       width: 64 bits
       clock: 33MHz
       capabilities: pciexpress msi pm vga_controller bus_master cap_list
       configuration: latency=0
       resources: iomemory:600-5ff iomemory:400-3ff memory:603e000000-603effffff memory:4000000000-400fffffff ioport:3000(size=64) memory:c0000-dffff memory:4010000000-4016ffffff memory:4020000000-40ffffffff
  • dmesg
➜  ~ dmesg | grep drm 
[    1.420124] systemd[1]: Starting Load Kernel Module drm...
[    1.428692] systemd[1]: modprobe@drm.service: Succeeded.
[    1.428949] systemd[1]: Finished Load Kernel Module drm.
[    1.667732] [drm] Your graphics device 9a49 is not properly supported by the driver in this

where the last one log is:

[drm] Your graphics device 9a49 is not properly supported by the driver in this
kernel version. To force driver probe anyway, use i915.force_probe=9a49
module parameter or CONFIG_DRM_I915_FORCE_PROBE=9a49 configuration option,
or (recommended) check for kernel updates.

there's another log concerning i915, I'm not sure if it's related:

snd_hda_codec_hdmi hdaudioC0D2: No i915 binding for Intel HDMI/DP codec

I guess the root cause is that the graphics card is not supported by the current driver i915. I don't know what to do or if there are other reasons for this issue. Here are what I have tried:

None of them works for me. I would be grateful if someone could give any help or ideas.

5

Everything that I’ve read about the Intel Xe graphics points to it needing a more current kernel than 20.04 currently offers. You will likely need to upgrade to 20.10 to get the most out of your new system.

1
  • Cool, it really works by upgrading to 20.10. Hopefully this won't bring me other issues. Thanks for your help. Btw, is there some way to look up whether a graphics card is supported by a specific kernel version? – Porcupine Andrew Dec 11 '20 at 5:54
6

I just got a new Asus Zenbook (UX425EA) yesterday which comes with 11th Gen i7 Processor + Intel Iris Xe Graphics, and I was facing the same problem too. After hours of google and scrolling through threads, I found one final fix which resolved the issue once and for all. You'll require the Ubuntu OEM kernel. Make sure to enable secure boot in the BIOS (last time I tried installing it without enabling the secure boot, the screen turned black with weird distortions, so I guess it will be an important step).

The following command does it all:

apt install linux-oem-20.04 && sudo reboot 0

If you have Intel Iris Xe MAX graphics, things get more complicated, refer here -> https://dgpu-docs.intel.com/devices/iris-xe-max-graphics/index.html.
This should do the job, but if it doesn't make sure that you have the packages as mentioned here -> https://dgpu-docs.intel.com/installation-guides/ubuntu/ubuntu-focal.html.

Hope this helps somebody. :)

1
  • Couldn't thank you enough. I was struggling for hours before i found this. Thank you so much for the fix. – Prakash Vishwakarma Apr 30 at 18:43
0

Please upgrade your kernel to 5.8 using:

sudo apt install --install-recommends linux-generic-hwe-20.04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.