Context: I purchased Cyberpunk 2077, and according to some articles (here, and here) - mesa-va-drivers 20.1+ are required.

I found the packages for mesa-va-drivers here, and followed the Howto on setting it up. After running sudo apt update, it says that updates are available, as shown below:

Listing... Done
mesa-va-drivers/focal-proposed 20.2.1-1~ubuntu0.20.04.2 amd64 [upgradable from: 20.0.8-0ubuntu1~20.04.1]
mesa-va-drivers/focal-proposed 20.2.1-1~ubuntu0.20.04.2 i386 [upgradable from: 20.0.8-0ubuntu1~20.04.1]

After attempting an upgrade, I get the following message:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 mesa-va-drivers : Depends: libllvm11 (>= 1:9~svn298832-1~) but it is not installable
                   Breaks: mesa-va-drivers:i386 (!= 20.2.1-1~ubuntu0.20.04.2) but 20.0.8-0ubuntu1~20.04.1 is to be installed
 mesa-va-drivers:i386 : Breaks: mesa-va-drivers (!= 20.0.8-0ubuntu1~20.04.1) but 20.2.1-1~ubuntu0.20.04.2 is to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

If it is relevant, I am using an AMD GPU (RX 580). Here is the output of uname -a (hostname omitted):

Linux 5.4.0-56-generic #62-Ubuntu SMP Mon Nov 23 19:20:19 UTC 2020 x86_64 x86_64 x86_64 GNU/Linux
  • What does this show? apt-cache policy mesa-va-drivers:i386 mesa-va-drivers libllvm11
    – doug
    Dec 10, 2020 at 8:14
  • Since it is too long for a comment, I've uploaded the results @ pastebin.com/C89ZAept
    – Zander
    Dec 10, 2020 at 21:53
  • It loooks like you may have switched from the US server to the Main server but didn't reload (update) your source. Please do that and try your upgrade again, i.e sudo apt update You need both libllvm11 & libllvm11:i386, both of which are certainly available in focal-proposed
    – doug
    Dec 10, 2020 at 22:32
  • Sorry for the possibly ignorant question, but how do I install libllvm11? I tried sudo apt install libllvm11, but it simply says there's no installation candidate. And yes, I did use sudo apt update before trying that command.
    – Zander
    Dec 10, 2020 at 23:00
  • Very weird. Notice that your apt-cache appears to locate the packages but doesn't as installable. You could download the 2 .debs and install manually if desired from here. Do you know how to do that? launchpad.net/ubuntu/+source/llvm-toolchain-11
    – doug
    Dec 11, 2020 at 0:14


You must log in to answer this question.

Browse other questions tagged .