Dell Latitude-E6500 3.2.0-24-generic #37-Ubuntu SMP x86_64 x86_64 GNU/Linux Graphics chip: Quadro NVS 160M Driver - 295.40

Here is my problem. My mouse lags in Ubuntu. It is always a few ms "late", and often not completely on target either. It is system-wide, not only when scrolling on web pages. The HW I am using is the same I used when running Kubuntu 11.10, which performed light years better compared to Unity - and, with no mouse lag what so ever. I am aware of the bug with the current Nvidia driver (295.40), but it is the same with the Noveau driver as well. It has nothing to do with setting the acceleration and sensitivity levels. It is the actual input that seems weird.

It is the same on a single laptop monitor and on my dual monitor setup.

Can it be kernel thing? Did they change how mousepolling is done? Any compiz tweaks available?

I plan to test this with Kubuntu 12.04 to see if it happens with KWIN too.


4 Answers 4


I've run into this before, and this fixed it for me. However, I've just changed this back to the original state, and it doesn't seem to be re-appearing. Perhaps it has been made moot by an upgrade -- but here's the process I used to fix it.

If you are running into the problem now, and just want to test real quick if this fix works, you can do the temporary:

sudo sh -c 'echo N > /sys/module/drm_kms_helper/parameters/poll'

To keep this change, do:

sudo sh -c 'echo "options drm_kms_helper poll=0" >> /etc/modprobe.d/local.conf'
sudo update-initramfs -u
  • 1
    This is on Bug #1008027.
    – Mr. B
    Jun 11, 2012 at 20:21
  • 2
    That file does not exist on my system.
    – Cerin
    Apr 27, 2015 at 14:51
  • ..this response was for Ubuntu 12.04, and aside from that, the specific issue I was having was later fixed via an update. If you're experiencing mouse lag now, it's likely a different issue.
    – Mr. B
    Apr 30, 2015 at 15:20
  • It did solve the issue, but why? How does it work? Jul 18, 2018 at 9:41
  • There's a bug in the graphics stack. Apparently, that bug either exists in drm_kms_helper, or is referenced by it when poll is 1. Turning off polling avoids the bug. To answer in any more detail, you'd need to get involved in kernel development. ..and, if you figured out exactly where in the code it was happening, you will have isolated the bug, at which point it's usually comparatively easy to fix. If you want to know more, you'll need to look into kernel development.
    – Mr. B
    Aug 8, 2018 at 15:36

I had the same issue (nVidia 9600m GT card), but only with NOUVEAU drivers (strange enough, previous ubuntu/nouveau versions works ok). I noticed the issue when mouse cursor is in "busy state" (the spinning animation), so i think there is something in cursor hw acceleration. Anyway, i solved using nvidia binary driver, "current-updates" version.


This is perhaps sacrilegious to say, but I've yet to have a good, sustained experience with Compiz, in any version of Ubuntu I've tried since 10.10 (including 12.04).

I've not experienced the mouse lag you've described, but I've noted other issues, that are laggy, buggy, or crashy. For instance, with more than 3 applications open (e.g. Inkscape, Thunderbird, Chromium, jEdit, Gnome Terminal), I regularly experienced noticeably varying lag when switching workspaces. The Unity launcher sidebar fails to hide or unhide. This doesn't happen immediately, but after 2 or three minutes of heavy use, these issues seemingly randomly appear. Then Compiz crashes, restarts, and it's okay again for a few minutes.

My solution: fall back to either the Unity 2D or Gnome (classic) interface.

Things have since stayed right zippy, and metacity does not crash but once in a blue moon.

If you need the effects that Compiz provides (which are nice!), then I hope someone else can suggest a more direct solution, rather than my workaround.

Of note, I'm using the same driver (nVidia) as you, with 256 MB graphics memory, 4GB of RAM, and a dual-core machine.

  • Owe people an update. First of all, thanks for the feedback. I have been very busy and haven't had a lot of time to investigate further. I had to go back to Win7. Ubuntu was simply slowing me down to the degree where it started to affect my efficiency at work. And guess what; IMHO Win7 beats Ubuntu at all levels expect for boot times. No graphical glitches, lagging or other similar wtf moments. My logitech H600 headset works too. I guess plug and play is true on Win7 :-) Anyway, I will try out the suggestions you have posted and report back.
    – Kenneth.
    Jun 14, 2012 at 7:55

I'm running 14.04 Xubuntu, currently 3.13.0-74-generic, and have the same problem. I've tried the

sudo sh -c 'echo "options drm_kms_helper poll=0" >> /etc/modprobe.d/local.conf 

solution suggested previously, and this helps, but only as a temporary fix. I've written a script program to perform it, but I've run it so many times. I examined the local.config file, and it just contains the one line repeated over and over again. I tried just touching the local.conf file instead, and that worked to temporarily fix the problem as well. Strange that a touch would do that. I'm going to see if I can touch a file that I don't need su privileges for, then I'll put it in a chron command to run every few minutes or so. This is all a workaround in lieu of a real solution.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .