Every couple of minutes, I receive a notification telling me that authentication is required. Clicking it prompts me to enter my network's password, but all I do is click "Continue" as the password is saved. In between these occurrences, my internet connection performs normally.

Current Potential Issues:

  • Being deauth Attacked (Unlikely as nothing on our home network would do this. Also, there are no deauth packets detected by Wireshark.
  • Interference/Weak Connection (Unlikely as this happens within 1 foot of the router.)
  • Bad Driver (Unlikely as I've been using this device with 20.04 since this April, and the issues started this month)
  • Issue with the Router (Unlikely as nothing has been changed in a while)

I've been using my home network for a while and it's been fairly reliable. We've never done much to the router except a bit of port forwarding, but all that happened a while ago.

I don't recall when this started, but every couple of minutes, I get this notification. Authentication required
It only happens on my laptop running Ubuntu 20.04. I have 2 other devices on the network running Ubuntu 20.04 (1 desktop and 1 server) and neither have issues like this nor does anything else on the network. I can click on the notification and it asks me to put in the password (which is saved, so all I do is click "Connect"). It can range from anywhere between 10 minutes (maybe more) to 30 seconds.

And the worst part is that a reboot won't fix it. I've checked for updates, installed them, and it says everything is up-to-date.

EDIT: I have logs for NetworkManager: https://pastebin.com/jCGwwXzJ Additionally, I've tried erasing the connection a couple of times from gnome-settings and nm-connection-editor. I've also made my gateway forget my device.

I tried using WPS on my latest attempt, and I still am asked every once in a while for my password.

EDIT 2: I have another partition running 18.04. The issue does not show on that partition. Additionally, I used my phone as a hotspot and the issue did not appear on my main partition running 20.04. This seems to be an issue when running 20.04 connected directly to my home network...

EDIT 3: I don't think I'm missing any firmware. I'll be running a few more tests, but I think this may be related to gaming. It happens frequently when on Minecraft, Among Us, or on a Discord call. Yes, I play Among Us on Ubuntu. Sometimes this happens on YouTube as well.

EDIT 4: I've noticed that the area with my wireless card is rather hot. Could overheating be the cause?

EDIT 5: Output from nmcli general permissions: | PERMISSION | VALUE | | ---------- | ----- | | org.freedesktop.NetworkManager.enable-disable-network | yes | | org.freedesktop.NetworkManager.enable-disable-wifi | yes | | org.freedesktop.NetworkManager.enable-disable-wwan | yes | | org.freedesktop.NetworkManager.enable-disable-wimax | yes | | org.freedesktop.NetworkManager.sleep-wake | no | | org.freedesktop.NetworkManager.network-control | yes | | org.freedesktop.NetworkManager.wifi.share.protected | yes | | org.freedesktop.NetworkManager.wifi.share.open | yes | | org.freedesktop.NetworkManager.settings.modify.system | yes | | org.freedesktop.NetworkManager.settings.modify.own | yes | | org.freedesktop.NetworkManager.settings.modify.hostname | auth | | org.freedesktop.NetworkManager.settings.modify.global-dns | auth | | org.freedesktop.NetworkManager.reload | auth | | org.freedesktop.NetworkManager.checkpoint-rollback | auth | | org.freedesktop.NetworkManager.enable-disable-statistics | yes | | org.freedesktop.NetworkManager.enable-disable-connectivity-check | yes | | org.freedesktop.NetworkManager.wifi.scan | unknown |

NOTE: I have limited access to the laptop due to another issue (unrelated to Ubuntu). Please be patient if I do not respond in time. Best of luck to all trying to help me with this!

  • Look at the logs! sudo journalctl -b 0 -u NetworkManager.
    – waltinator
    Dec 7 '20 at 18:57
  • Just rebooted (for something else). Will wait for something to come up. Dec 7 '20 at 19:01
  • @waltinator Here's the logs. pastebin.com/jCGwwXzJ Dec 7 '20 at 20:22
  • try to delete the connection using nm-connection-editor and then connect again and check if the issue is still there
    – kannzzmm2
    Dec 9 '20 at 19:33
  • Nope, didn't work. Dec 9 '20 at 19:46

Because I can't commend I will just post it here, I know it's wrong but I'm trying to help.

Try ubuntu-drivers devices it will run for a while but if it detects a missing wifi driver it will let you know, if it does, execute sudo apt install <name of driver>

You said that it only happens to your home AP? try setting your phone the same name (SSID) and password as your home router and wait to see if it will happen again (be sure to be out of range of your actual wifi router of turn it off).

Additionally, you can try changing your routers SSID to see if the name was cusing the problem (quite rare!), try deleting your network from the memory and connect again, this should resolve any issues.

Also you can try a live iso from a usb to see if the problem will continue to exists even on a different "installation".

  • Not a driver issue, it's only started happening within a month. Dec 16 '20 at 20:08

I think this is problem/misconfiguration in your router. First I would disable all security on the router and check if this problem is gone. If so you located the problem in your router.

Then you can enable security again and set a new password. I would suggest to use WPA2 + AES since that delivers good protection against entruders.

  • If it was an issue with the router, everything would have that issue, right? My laptop is the only device with this issue Dec 9 '20 at 19:36
  • Not in every case. If password and/or encryption keys are ok other devices may work. To make sure the problem is your router I would recommend turn off security first connect your laptop and enable it again. Dec 9 '20 at 19:44
  • It's an XFINITY router... I can't disable security Dec 9 '20 at 19:46
  • @CStafford-14 how far away from your router are you?
    – Thomas Ward
    Dec 11 '20 at 15:21
  • I'm normally about 10-12 feet below the router, but this happens when I'm within 1 foot with nothing between them. Dec 11 '20 at 15:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.