30

Ubuntu 20.04 won't wake up from sleep

Issue:

  • Whenever the laptop suspends (either due to a closed lid or due to a black screen for a certain time), I cannot wake it up.
  • The laptop does not respond to keystrokes and power button clicks. As a result, I always have to hold the power button to shut it down and then power it up again.

System:

  • Model: Dell Inspiron 15 3593
  • Processor: Intel® Core™ i5-1035G1 CPU @ 1.00GHz × 8
  • Graphics: Mesa Intel® UHD Graphics (ICL GT1)
  • RAM: 16GB DDR4
  • Storage: 512GB SSD + 1TB HDD
  • OS: Ubuntu 20.04 LTS 64bit

Extra info:

Thank you in advance!

Update:

  • Tried GRUB_CMD_LINUX="nouveau.modeset=0" in grub config and it didn't work.
  • Tried GRUB_CMDLINE_LINUX="nouveau.blacklist=1" in grub config and it didn't work.
  • I switched to an old kernel version: 5.0.0-1070-oem-osp1 and made it the default choice because under this kernel the issue is resolved.
  • I used this guide for changing the default kernel: How can I boot with an older kernel version? . Thank you @B.Tanner for the idea. I really hope that it will be fixed for newer Kernels in the future.
  • Reported bug here: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1909005
8
  • On my Inspiron 17 3793 (sounds like it might be similar!) I have to use the original 20.04 kernel for wakeup-from-suspend to work, see askubuntu.com/questions/1292365/….
    – B.Tanner
    Dec 7, 2020 at 14:52
  • Thank you @B.Tanner for sharing this idea! I booted with an old kernel version and it seems to work fine. I used this thread to make the old kernel default: askubuntu.com/questions/82140/…. Dec 9, 2020 at 11:10
  • great, I'm glad it's not just me :-) it means it might get fixed. I have been running the old kernel fine for a while now, suspending all the time. I have had new kernels come through with apt update but they did not replace the old kernel so it is still good. Of course it's not ideal having to run an old kernel without security updates etc but it'll do for me for the time being.
    – B.Tanner
    Dec 9, 2020 at 16:35
  • @B.Tanner I have reported this bug here: bugs.launchpad.net/ubuntu/+source/linux/+bug/1909005 . Please click the "this bug affects me button" and if we are lucky someone may see into it. Dec 22, 2020 at 20:44
  • thanks; have done so and added some new observations on symptoms
    – B.Tanner
    Dec 22, 2020 at 23:06

8 Answers 8

11

With Dell notebooks I generally configure them like this:

  1. Open the terminal
  2. Install the necessary drivers with ubuntu-drivers autoinstall
  3. Disable the fallback service with sudo systemctl disable nvidia-fallback.service
  4. Then edit /etc/default/grub and add the line: GRUB_CMDLINE_LINUX="nouveau.blacklist=1"
  5. Update Grub with: sudo update-grub
  6. Reboot

With this my colleagues can suspend/hibernate-resume without too many issues … though there are occasional hiccups for people who suspend for 4+ days.

Hope this works for you, too 👍🏻

12
  • I tried it all and it didn't work. Dec 7, 2020 at 15:12
  • Are there any errors in the system log? If so, could you update your question to include them? This might make it easier to find the best solution.
    – user1091774
    Dec 7, 2020 at 15:31
  • Thanks for pointing out. I have just uploaded system logs. Dec 7, 2020 at 16:11
  • Also i would like to point out that there was no nvidia-fallback.service. Dec 7, 2020 at 18:06
  • 1
    +1 step 4 and 5 was all that was needed for me, steps 2 and 3 were not needed (no updates and no service)
    – ljden
    Dec 18, 2020 at 22:42
4

This fixed it for me (found after searching for "suspend" in journalctl -r). Final solution posted by apienk to remove damaged symlinks: https://bugs.launchpad.net/ubuntu/+source/systemd/+bug/1933880

I hope it helps someone

2
  • 2
    While this link may answer the question, it is better to include the essential parts of the answer here and provide the link for reference. Link-only answers can become invalid if the linked page changes. - From Review Feb 8 at 7:54
  • This answer is very much driver version and overall spec dependent and is not a general solution. I'd advise not to take this approach, i.e. deleting the links in /etc/systemd/system unless you are certain and know what you're doing. Check your specs (e.g. cat /proc/driver/nvidia/version and journalctl -b |grep suspend for errors ). As a counter-e.g., the power-management docs for 510.85.02 states the need and usage of the links (download.nvidia.com/XFree86/Linux-x86_64/510.85.02/README/…).
    – John Doe
    Oct 23 at 16:07
3

I'm having very similar problem with the difference of these specs

  • Model: Dell Latitude 5490
  • Processor: Intel® Core™ i5-8250U

After a long time searching online and trying different unsuccessful fixes I've found this article where @davze assumes that:

Kaby Lake processors seem to have problems with C-States on recent kernels

and proposes limiting c-states. Your CPU family seems to be different

(Ice Lake), but you can try it too, adding

acpi_enforce_resources=lax i915.enable_dc=0 intel_idle.max_cstate=1

to GRUB_CMDLINE_LINUX_DEFAULT in /etc/default/grub. Run sudo update-grub and reboot to see the effect. Now my system can suspend and wake up properly, but unfortunately as the author of the article has mentioned: Limiting the cstates is of course killing the battery....

PS:

acpi_enforce_resources - allows access to resources claimed by ACPI read more

i915.enable_dc=0 - disables GPU power management

intel_idle.max_cstate=1 - limits allowed c-states read more

1
  • Good solution, well presented. This must be why my blazing fast 8250u was so cheap.
    – John
    Sep 11 at 16:50
2

I know that this is an old post, but I frequented this constantly over the last few weeks trying to find an answer and I thought hopefully someone else will come along like me and see this instead.

In Terminal I ran uname -sr and it returned Linux 5.13.0XXXXXXX-generic I then went to here and scrolled down to the bottom.

This is the different updates for Ubuntu. I ignored the rc* files, and found the most recent, which in my case was v5.15/

When you click on that folder, you want to download the amd64 sets. Which is the first set of links. You want:

amd64/linux-headers-5.15.0-051500-generic_5.15.0-051500.202110312130_amd64.deb

amd64/linux-headers-5.15.0-051500_5.15.0-051500.202110312130_all.deb

amd64/linux-image-unsigned-5.15.0-051500-generic_5.15.0-051500.202110312130_amd64.deb

amd64/linux-modules-5.15.0-051500-generic_5.15.0-051500.202110312130_amd64.deb

You'll notice that all of these names have 'generic' in them instead of 'low latency', except for the one that contains 'all'.

Download those files, and chuck them in a folder. For simplicity I had them under Documents/kernels/5.15/

(I created these folders, they don't already exist aside from Documents).

I then went cd Documents/kernels/5.15/ followed by sudo dpkg -i *.deb This installs all of those files you just downloaded. Make sure you're in the correct folder, or *.deb will install any file with that suffix.

It will take a few minutes to install. Once installed I wanted to check that it had been installed.

apt list --installed | grep linux-image You should get a list of the currently installed versions. For me I had two 5.13's and my newly installed 5.15

At this point I uninstalled 5.13 with sudo apt remove linux-image-5.13.0-19-generic (you will of course have to replace the 5.13.0-19 with whatever version you are running). If you are uncomfortable uninstalling, you can wait or not do it at all. It's not a necessary step.

sudo reboot

At this point, if you do not usually start with a boot to GRUB, hold down your SHIFT key. Under Advanced Options, I manually selected 5.15

I was told that I had an invalid signature. To fix this, I ran 5.13 again, then rebooted, went into the GRUB settings, and located a way to disable Secure Boot. Each laptop will be different so I'm sorry I can't be more help here, but the settings should be fairly easy to navigate.

Feel free to do your own research on whether or not you should disable Secure Boot. Don't listen to strange people on the internet.

With secure boot disabled, I could launch 5.15, I tested it several times, and my suspend issues were over!

Hopefully this helps anyone else.

1

what worked for me:

sudo systemctl disable nvidia-suspend

which leads to the output:

Removed /etc/systemd/system/systemd-suspend.service.requires/nvidia-suspend.service.

Some more comments about it: ubuntu-20-04-with-nvidia-460-driver-freezes-randomly-after-resume-from-suspend-hibernate

2
  • Hello. Your answer needs more details. Example What does this command do.
    – David
    Apr 9 at 12:09
  • 1
    Not a link actual info. The link could be gone in the future.
    – David
    Apr 9 at 14:19
1

I was struggling with the same issue on my new Dell Inspiron Laptop. I found a way to make sleep to RAM work as it should on my Kubuntu 21.10 system.

You have to recompile the DSDT (Differentiated System Description Table) which is part of the ACPI managagement module which manages power related events.

Here is a blog post including instructions:

https://dev.to/epassaro/fix-suspend-issues-on-dell-7405-2-in-1-3l1b

According to the author of that blog post, the DSDT seems to be compiled for Windows out-of-box and deactivates sleep to RAM (S3). Instead, it assumes usage of "modern/connected standby" (S0ix) that Windows uses. Apparently some AMD CPUs may not support this on Linux. As the blog post suggests run:

$ sudo dmesg | grep -i acpi | grep supports

The output should look something like this:

[    0.357470] ACPI: (supports S0 S4 S5)

If you don't see S3 for sleep to RAM there, the instructions in the blog post may help you activate sleep to RAM (S3).

Addendum: On a Lenovo P14s running Ubuntu 20.04 LTS with an AMD Ryzen 7 pro 5850u, this problem also occurred. In Step 2 of the instructions, recompiling dsdt.dsl did not show any errors for me but I could simply skip that step.

Also, in Step 3 of the given instructions where the dsdt.dsl is modified, I could not find the exact piece of code the author suggests to replace. Instead my dsdt.dsl contained the following lines (searching the file for "System State" showed the according active entries for S0, S4 and S5 for me; the deactivated S3 entry was located in that part of the file):

Name (NOS3, Package (0x04)
{
    0x03, 
    0x03, 
    0x00, 
    0x00
})

However, replacing those lines by the following lines suggested by the author also worked to activate S3 for me:

Name (_S3, Package (0x04)  // _S3_: S3 System State
{
    0x03, 
    0x03, 
    Zero, 
    Zero
})
0
0

I had the same problem, I have a Lenovo AMD A9 with Ubuntu 20.04, the problem started when the power and the capital letter indicator in my keyboard doesn't turned off, after that the pc doesn't turn off totally, then some times don't booted the ubuntu, and another times started. Finally, when the PC turned on, the pc showed me a black display blinking and never started.

I installed 5 times the ubuntu 20.04 and It don't worked, I installed ubuntu 21.10 and again nothing. Finally, I created the USB bootable using this steps (https://www.linuxtechi.com/create-bootable-usb-disk-dvd-ubuntu-linux-mint/), but using ubuntu-18.04-desktop-amd64.iso (be carefull because some ISO images are bad), and I used the "Make startup Disk" in Ubuntu, I booted the pc and I installed totally the ubuntu 18.04, after that my pc worked fine, with afraid update the ubuntu to 20.04 version, but the computer worked fine.

That was my experience, and I write with detail because I am not developers, only a normal user, and I saw many blog and foros, but with a specializaed language. So I hope that can be help.

0

Here's a hack i have found out. It works for me.

Whenever you want to suspend your PC just keep any App pr Tab Open on Screen (Like browser, any app).

Don't suspend on desktop screen. (If you suspend on Home Screen(Desktop Screen) then you won't be able to see the desktop screen after waking up, though your CPU will be ON.

If it works for you kindly let me know.

1
  • Your answer could be improved with additional supporting information. Please edit to add further details, such as citations or documentation, so that others can confirm that your answer is correct. You can find more information on how to write good answers in the help center.
    – Community Bot
    Nov 1 at 15:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.