1

I am altering the keyboard configuration in Ubuntu 20.10 via

gnome-tweaks

and then, in Keyboard and Mouse/Additional Layout Options I set Alt/Win key behavior to "ctrl is mapped to Win and the usual ctrl keys", since I'm using a the mac magic keyboard.

enter image description here

This choice however is reset each time I lock the screen, so I have to keep resetting it.

Is there a way to fix this?

System details:

enter image description here

enter image description here

6
  • I am using 20.10
    – apkg
    Dec 7 '20 at 12:26
  • I restarted this way by entering r as a command in the command box. I will restart the pc to see what happens.
    – apkg
    Dec 7 '20 at 12:30
  • Ok configuration resets again, so this has not fixed it.
    – apkg
    Dec 7 '20 at 12:36
  • What should I edit? I can see im-launch and SSH keyring.
    – apkg
    Dec 7 '20 at 12:38
  • 1
    Does anyone have a solution to this? I have 3 keyboard settings. All of them gets reset after screen lock. I always have to go back and toggle off and on a setting to get all 3 setting to take effect again.
    – sang
    Dec 15 '20 at 17:53
2

This is a confirmed bug in mutter: https://bugs.launchpad.net/ubuntu/+source/mutter/+bug/1899206

A fix has been released for 20.04 so try upgrading and checking the version:

sudo apt-get upgrade mutter
mutter --version
1

Technically not the answer to your question because it does not fix "gnome-tweaks"...

but in a terminal try:

gsettings set org.gnome.libgnomekbd.keyboard options  "['altwin\taltwin:ctrl_win']"

to try to fix the problem you're trying to remedy...

5
  • Do I need to run this at startup i.e. each time?
    – apkg
    Dec 8 '20 at 15:56
  • @apkg ...you tell us
    – WU-TANG
    Dec 8 '20 at 16:42
  • Ok, I will see if it resets. If it does, I will add it via cron
    – apkg
    Dec 8 '20 at 16:42
  • @apkg ...did it work at all? did it persist through a reboot? I am also curious for my own reasons, but I dont believe I have the right equipment to test it with.
    – WU-TANG
    Dec 10 '20 at 1:56
  • I just checked and I think it did not!
    – apkg
    Dec 10 '20 at 2:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.