1

im absolutely stuck on getting

Ubuntu Studio 20.04 + Ardour 5 + EMU 0404 PCI

working as it should.

I did install Ubuntu Studio on an old PC of a buddy of mine. He wants to do some recordings and it is perfect to "recycle" the old machine. This PC includes a EMU 0404 PCI.

I already googled many sites and did many things

  • re-installed ardour & ubuntu studio controls
  • re-installed jack
  • tried to install driver/firmware for emu0404

What is working:

  • Playing recorded stuff --> Output to stereo-out works
  • Jack seems to work
  • Running a Behringer U-Phoria UM2 (USB) Device worket --> Playback AND Recording --> But this device should not be used --> EMU 0404 already included in the PC

What is not working:

(This is the reason im posting this)

  • I can not use the EMU0404 stereo-input to record stuff --> No matter what connections in ardour i make or what additional devices i add in the ubuntu studio controls --> I never got it working, that the (directly into the stereo input) plugged in guitar gets routet to the input of ardour

Due to the fact that everything is there and and works, i think that i dont understand all the dependencies in the whole system (Ubuntu Studio Conrols / Qjackctl / Pulse Audio / Ardour Channels/Buses/Hardware/Setting)

I have no clue what to try next, this is the reason why im asking for help of you guys. But im annoyed that im near the finish and only the very last thing ("Getting the input-signal working") is not working.

Below im trying to post as much information as possible, so maybe one of you can tell me what i am doing wrong!

Thanks a lot in advance!

inxi -Fxxxrz\n\n

System:
  Kernel: 5.4.0-56-lowlatency x86_64 bits: 64 compiler: gcc v: 9.3.0 
  Desktop: Xfce 4.14.2 tk: Gtk 3.24.13 info: xfce4-panel wm: xfwm4 
  dm: LightDM 1.30.0 Distro: Ubuntu 20.04.1 LTS (Focal Fossa) 
Machine:
  Type: Desktop System: Olidata S.p.A. product: N/A v: N/A serial: <filter> 
  Mobo: ASUSTek model: M2NPV-VM v: 1.xx serial: <filter> BIOS: Phoenix 
  v: ASUS M2NPV-VM Revision 5005 date: 06/02/2010 
CPU:
  Topology: Dual Core model: AMD Athlon 64 X2 5600+ bits: 64 type: MCP 
  arch: K8 rev.F+ rev: 3 L2 cache: 2048 KiB 
  flags: lm nx pae sse sse2 sse3 svm bogomips: 11224 
  Speed: 1000 MHz min/max: 1000/2800 MHz Core speeds (MHz): 1: 1000 2: 1000 
Graphics:
  Device-1: NVIDIA G84 [GeForce 8400 GS] driver: nouveau v: kernel 
  bus ID: 01:00.0 chip ID: 10de:0404 
  Display: x11 server: X.Org 1.20.8 driver: modesetting unloaded: fbdev,vesa 
  resolution: 1920x1080~60Hz 
  OpenGL: renderer: NV84 v: 3.3 Mesa 20.0.8 direct render: Yes 
Audio:
  Device-1: NVIDIA MCP51 High Definition Audio vendor: ASUSTeK 
  driver: snd_hda_intel v: kernel bus ID: 00:10.1 chip ID: 10de:026c 
  Device-2: Creative Labs CA0108/CA10300 [Sound Blaster Audigy Series] 
  driver: snd_emu10k1 v: kernel bus ID: 02:08.0 chip ID: 1102:0008 
  Device-3: Thomann SWISSONIC EasyKeys25 type: USB driver: snd-usb-audio 
  bus ID: 2-3:3 chip ID: 07fc:1110 
  Sound Server: ALSA v: k5.4.0-56-lowlatency 
Network:
  Device-1: NVIDIA MCP51 Ethernet vendor: ASUSTeK type: network bridge 
  driver: forcedeth v: kernel port: f200 bus ID: 00:14.0 chip ID: 10de:0269 
  IF: enp0s20 state: up speed: 100 Mbps duplex: full mac: <filter> 
Drives:
  Local Storage: total: 698.64 GiB used: 31.88 GiB (4.6%) 
  ID-1: /dev/sda vendor: Hitachi model: HTS541075A9E680 size: 698.64 GiB 
  speed: 3.0 Gb/s rotation: 5400 rpm serial: <filter> rev: B480 scheme: MBR 
Partition:
  ID-1: / size: 668.19 GiB used: 31.74 GiB (4.8%) fs: ext4 dev: /dev/sda2 
  ID-2: /boot size: 944.6 MiB used: 142.1 MiB (15.0%) fs: ext4 
  dev: /dev/sda1 
  ID-3: swap-1 size: 17.82 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda3 
Sensors:
  System Temperatures: cpu: 40.0 C mobo: N/A gpu: nouveau temp: 31 C 
  Fan Speeds (RPM): N/A gpu: nouveau fan: 0 

Already tried this to re-install alsa firmware:

cd ~
wget ftp://ftp.alsa-project.org/pub/firmware/alsa-firmware-1.0.28.tar.bz2
tar xjf alsa-firmware-1.0.28.tar.bz2
cd alsa-firmware-1.0.28
./configure --enable-buildfw
cd emu/
make
sudo make install

And here as many screenshots as possible:

At the moment i completely lost the overview what do connect or activate

Ardour1

Ardour2

Ardour4

UbuntuStudioControls3

UbuntuStudioControls4

UbuntuStudioControls5

qas mixer

qjackctl

28
  • The screenshot of qasmixer shows only output devices, but we need to see capture devices. Also scroll down with the small scrollbar beside the two buttons in the lower right corner to see more options, best to make the window bigger so all options fit in the window. – mook765 Dec 6 '20 at 14:37
  • Hello mook765, thanks a lot! I dont know how to switch to "capture" devices ... this is all i can see here: dropbox.com/s/2nti282bv7vh5lt/… – SHUred Dec 6 '20 at 16:18
  • You can switch displaying playback and capture devices on and off with te two buttons in the right lower corner. – mook765 Dec 6 '20 at 16:22
  • Aaaah! Now i get it! Seems like some of the inputs are deactivated hah? Is the "stereo in" something like "aux"??? dropbox.com/s/lbs0p4p1pte183a/… – SHUred Dec 6 '20 at 16:29
  • It's hard to see due to dark theme. You'll have to try out a bit. I use only built-in audio which has totally different options. Also check the connections inside jack with carla, maybe this gives a clue. – mook765 Dec 6 '20 at 17:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.