Possible Duplicate:
How do I fix this “E:Type '*' is not known on line * in source list …” update error?

Please refer to the attached screen-shot. This error comes every time I boot and now I am unable to get any updates.

Also, the Ubuntu Software Center will no longer work. I click on the USC icon and nothing happens.

Could not initialize the package information An unresolvable problem occurred while initializing the package information. Please report this bug against the 'update-manager' package and include the following error message:

'E:Type 'sudo' is not known on line 61 in source list /etc/apt/sources.list'

I am using Maverick Meercat Netbook. Please advise how to resolve this problem.

Thanks for your help.

EDIT - LINK to the sources.list file.

enter image description here

marked as duplicate by htorque, Stefano Palazzo Jan 19 '12 at 23:36

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.


Your error was:

'E:Type 'sudo' is not known on line 61 in source list /etc/apt/sources.list'

Thanks for provide us the pastebin of your source list. After look at it, I could certainly identify where is the problem. Look at the screenshot below:

enter image description here

The lines that need to be purged out of the file are highlighted in the image above. Now lets remove it (follow up the instructions below):

  • Open a Terminal and type gksu gedit /etc/apt/sources.list
  • Go to line 61 and remove from line 61 (starting with sudo) until line 64 (where you will see exit).
  • Save and exit from gedit. Go back to your terminal and type: sudo apt-get update

Now you can proceed :-)

Would be very nice for your skills if you spending a little time reading some docs about syntax of repository files and its configuration. learn how Ubuntu works will make you a better user every day, including able to collaborate. Here are two links that will help with your journey in Ubuntu:


Please help us to see you /etc/apt/sources.list: Submit your sources.list file at the Ubuntu Official Pastebin, after edit this Ask to include the link. Thanks!

  • paste.ubuntu.com/531519 – Prateek Mishra Nov 14 '10 at 3:20
  • Here is the link to the list file. – Prateek Mishra Nov 14 '10 at 3:21
  • Delete not sudo but all 61 line - its nonsense here – Extender Nov 14 '10 at 3:32
  • I just deleted the entire 61st line. Error still persists and Software Center still doesn't shows up. :'( – Prateek Mishra Nov 14 '10 at 3:50
  • Thank you very much for your time and help. It worked. And those links are really helpful. :) – Prateek Mishra Nov 15 '10 at 15:04

As it says, you have a mistake in your sources list.

To open the sources list in Gedit Text Editor, open a Terminal and input the command: gksudo gedit /etc/apt/sources.list.

When the sources list is open look at line 61. Do you see a mistake? You can make this line ineffective by putting at the beginning of the line: #

If you can't see a mistake, or it is too difficult for you, Copy and Paste the list here.

  • The 61st line was as follows. I placed a # rebooted after saving the file, but problem persists. – Prateek Mishra Nov 13 '10 at 12:10
  • sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 886DDD89 – Prateek Mishra Nov 13 '10 at 12:11

Not the answer you're looking for? Browse other questions tagged or ask your own question.