0

I got a new laptop the other day and I've been trying to dual boot it with Ubuntu 20.04.1 alongside the preinstalled Windows 10.

I made a live USB stick using etcher and shrunk my C drive to make space for the Ubuntu installation.

I booted into the live USB stick and did a default "Install Ubuntu alongside Windows" installation. It seems to go completely smoothly and I reboot.

This is where the trouble begins. The computer reboots straight into Windows, completely missing GRUB. This seems ok because I can just change the boot order. I do so and again it boots straight into Windows. I even tried running GRUB by selecting Ubuntu in the boot options and this gave me "The selected boot device failed."

I've tried reflashing my USB stick with a new download of the Ubuntu ISO file and then reinstalling Ubuntu but I've been getting the same result.

I even tried using boot-repair from the USB stick and this doesn't even show the "recommended repair" button.

Here are the details: Machine: HP Pavilion Boot mode: UEFI (both Windows and Ubuntu) Installing: Ubuntu 20.04.1

SSD partitions: /dev/nvme0n1p1 EFI System /dev/nvme0n1p2 Microsoft Reserved /dev/nvme0n1p3 Windows /dev/nvme0n1p4 Windows recovery environment /dev/nvme0n1p5 Linux filesystem

Edit: Here's the pastebin for the boot-repair summary report: https://paste.ubuntu.com/p/Kzm8vhjsc4/

6
  • HP's are not particularly dual boot friendly. Some with HP have said updating UEFI & SSD firmware & then only using UEFI to change boot order works. Most systems let you use efibootmgr to change boot order & efibootmgr is what grub uses to change boot order to make grub/Ubuntu first in boot order. – oldfred Dec 4 '20 at 22:24
  • The issue I think I have is less to do with the boot order and more to do with the actual installation because not even boot-repair run from a live USB stick can access it. – dani3l_5 Dec 5 '20 at 0:05
  • Then post link from Boot-Repair's Summary Report above in your question, so we can see details. – oldfred Dec 5 '20 at 4:02
  • I've done just that – dani3l_5 Dec 5 '20 at 10:52
  • 1
    It is trying to show it as RAID, but probably is UEFI setting for Intel RST. discourse.ubuntu.com/t/… & superuser.com/questions/1280141/… Also make sure Windows fast startup is off. askubuntu.com/questions/843153/… & askubuntu.com/questions/145902/… & help.ubuntu.com/community/UEFI – oldfred Dec 5 '20 at 14:36
2

Oldfred has provided an answer using the boot-repair summary. My computer was using Intel RST and RAID which meant that Ubuntu could not boot. I turned this off and Ubuntu loads just fine.

1
  • 1
    I was having issues installing ubuntu on my lenovo ideapad yesterday and it had the same issues due to Intel RST. I just turned it off from BIOS and yeah installation went perfectly after that. – john400 Dec 5 '20 at 16:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.