0

I've been using Ubuntu 16.04 LTS for about 3 years now, and finally used up all the space on my 1TB HDD. So I cloned my entire old 1TB HDD to a new 2TB SSD with gparted, expecting the outcome to be an exact clone, partitions and all, and bootable. When I installed the SSD into my computer (old Compaq CQ71, Celeron CPU 900 @ 2.20GHz) and tried to boot into Ubuntu (no dual boot, just Ubuntu 16.04 LTS), I got the black screen with "no bootable device" message.

I checked the new SSD with gparted, and it appears there's only one partition on it: /dev/sda1 (ext4), instead of the 3 on the original HDD. Also, the new SSD had about 20 MB less data than the HDD it was cloned from.

I tried booting with an external drive with a bootable copy of windows 7, and that opened fine (automatically, with no intervention from me).

I tried booting from the original 1TB HDD (that the new 2Tb SSD had been cloned from) via USB port, and that did not work straight out (same "no bootable device" message).

By fiddling around, I found out I can boot into Ubuntu, but only by connecting the old HDD to the PC via USB port, and changing the boot order in BIOS during startup between "notebook hard drive" and "USB hard drive". The original order between the 2 does not matter: I can only boot after switching one for the other.

Once I confirm the change in BIOS, I get:

  • a purple screen with "GNU GRUB version 2" and "Ubuntu" highlighted, and once I press enter,
  • a black screen with:
  • [ 3.044423] sd 6:0:0:0: [sdb] asking for cache data failed
  • [ 3.044471] sd 6:0:0:0: [sdb] assuming drive cache: write through
  • /dev/sda1: clean followed by a file and blocks count.

Then it boots into Ubuntu, and I can disconnect the old HDD, and the PC works as usual until I have to start my computer again.

From my novice viewpoint, the fact that only 1 partition was cloned (or the 3 original were merged into 1?) is suspect, and there's evidently an issue with the boot process. So I guess my question is: can I fix the boot process without compromising the data on the SSD (it took 14 hours to clone), or having to repeat the whole clone process?

11
  • 1
    Sas far as I can remember gparted does not clone the whole drive. You have to clone each partition separately. Don't forget to click the Apply button after each operation.
    – user68186
    Dec 3, 2020 at 19:07
  • 16,04 will be EOL on april 30th 2021 it would be best to install 18.04 or 20.04 then just copy any files you want from the old drive to the new one Dec 3, 2020 at 19:11
  • @user68186 I did anticipate there might be a problem there: gparted only allowed me to copy sda1. When selecting sda2 and sda5, the 2 other partitions, "copy" was grayed out. Obviously, it's too late to try to add them now, right? Dec 3, 2020 at 19:21
  • It looks like sda2 may be an extended partition and sda5 may be a logical partition within the extended partition. I have never tried to clone extended and logical partitions.
    – user68186
    Dec 3, 2020 at 19:28
  • @wraith3690 001 I thought I'd read that 16.04 LTS's EOL had been pushed back to 2024, but it turns out that's with ESM. I might have to consider a fresh install of say 20.04, but I'd chosen to clone my system to avoid the time-consuming task of having to reinstall all my software and settings, passwords etc.. On the other hand, I might just be able to simply update to 18.04 if this boot problem gets sorted out. Dec 3, 2020 at 19:36

1 Answer 1

0

and happy new year!

I finally got around to creating a working live ubuntu usb drive, as well as a full ubuntu usb flash drive. Both boot correctly, but neither allows me to access any of the files on the computer's dedicated ssd.

Until a few days ago, I had to boot my pc through my old external hdd, and that landed me on my system, files and all. My old hdd started clicking, and won't boot any more. I've since been trying to boot into the pc via the usb drives, but they boot as generic "trial" systems instead of my ssd.

I intend to order a new ssd to backup my files before I try repairing grub (just in case), but in the meantime, is there any way to gain access to my files through the usb "trial" ubuntu system?

2
  • @C.S.Cameron So I've made some progress since yesterday: I ran boot repair, and got the following message: "GPT detected. Please create a BIOS-Boot partition (>1 MiB, unformatted filesystem, bios_grub flag). This can be performed via tools such as Gparted. Then Try again. So I did just that, and went through the Boot repair process again, and obtained a "Boot successfully repaired" window. However, trying to boot from my new ssd remains unsuccessful, and I get an error message that ends with [end Kernel panic - not syncing: Attempted to kill init! exit code=0x00000200. Jan 2, 2021 at 18:19
  • .... In Gparted, both my partition copied from my old HDD appears: /dev/sda1 (with a key next to it), and the one created through Gparted flagged bios_grub: /dev/sda2 (with an exclamation point next to it). On the other hand, booting from the full ubuntu flash drive, the 2TB ssd now appears, and I can access my old coputer files from there. Any idea on what's still keeping the boot process from working? Jan 2, 2021 at 18:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.