I just installed 12.04 to Dual Boot (separate partitions) with an existing Win 7. Upon reboot after install things freeze after Grub 1.5 with a Grub Error 15 message.

Is there any easy way to fix this? (I am posting this from my second computer)

UPDATE: I managed to boot into both 12.04 and Win7 using BIOS:

  • Selected the disk with the Win7 'C' Partition: resulted in the same error message
  • Rebooted, tried the disk with the Ubuntu Partitions: *Grub Menu loaded:
  • Managed to boot 12.04, rebooted, used BIOS again:
  • Managed to boot Win 7

So, I have access to my computer again (thru BIOS), but this has been a pretty crappy install experience.


I used the the Final release 12.04 Ubuntu install disk, reformatted all Linux partitions, and expected a simple clean install. Other than specifying the Ubuntu Partitions, I did a basic install of 12.04. No way I did do anything to get this crap error failure! I have no idea why my install resulted in a Grub-15 error.

  • grub2 does not have stage1.5 or error 15, and you should not be using grub legacy on a fresh install of 12.04. I believe wubi installs use GRUB4DOS which is a fork of grub legacy, are you sure you didn't do a wubi install? Running this script ( from the livecd ) and adding its output to your question would help: sourceforge.net/projects/bootinfoscript/ – psusi May 2 '12 at 1:21

OP posted:

I burned a RescuTux Disk and used it to recover grub2 (simplest and easiest way for me. http://www.supergrubdisk.org/category/download/rescatuxdownloads/


Grub error 15 list that "file not found", because of the wrong table of partitions. You can reconfigure your partitions by editing menu.lst file found in


For that, you can use live cd to open up terminal and type:

sudo fdisk -l | grep -i linux

This will list out the linux partitions and check the entry if the linux root device and swap device entry are correct. You can use disk monitor to view that in fancy mannar. If they are on the way, then you just have to reboot the system. check more out here if you have problems.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.