This seems very common topic these days but i have some additional problems. The additional drivers option is greyed out, and it says there are no drivers being used. The graphics driver shows "unknown" in the system settings and i cant configure multiple monitors as it wont detect displays at all. I have the latest driver from Nvidia 295.40 installed. I also tried to manually start X server by sudo service lightdm start and contrary to the config settings it says its already running

I have an dell XPS with Nvidia GeForce GT 420M. Thanks in advance

Please follow links for images

  • install mesa-util to show driver information. What does happen after run sudo nvidia-xconfig (and restart)? edit /etc/default/grub with root permission. sudo geidt /etc/default/grub [ change the line GRUB_CMDLINE_LINUX="nomodeset" . save and close. now run: sudo update-grub [restart]. – shantanu May 1 '12 at 21:56
  • Hi @shantanu, thanks for helping me out, but it doesnt seems to work, I dont know exactly how to restart xserver, I used service lightdm start.</b>It gives me back - "start: Job is already running: lightdm"</b> Would try nomodest, tried nopat but that didnt work... – Nakul May 2 '12 at 1:57
  • nomodeset doesnt works, it takes away even the widescreen resolution... – Nakul May 2 '12 at 2:20
  • Any help!!! Please I also noticed that i dont get an option to change icon size in display menu for unity. So has to be that ubunutu doesnt thinks i have a graphics card at all.. – Nakul May 8 '12 at 18:08
  • possible duplicate of How well do laptops with Nvidia Optimus work? – Jorge Castro May 14 '12 at 5:48

I used Ironhide driver using the approach here:- http://community.linuxmint.com/tutorial/view/610

It worked fine in Ubuntu 11.10 although I have a few problems in 12.04. The graphics works fine but I get error messages. I have an Acer Aspire with the same graphics card as you. This runs compiz, gives Unity 3D etc but is not perfect. The Nvidia drivers do not work in Ubuntu although that may change.

Good luck

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.