2

Just bought a new Dell XPS 13 9300 and tried to install Ubuntu 24.04.1. Wifi wont work neither bluetooth, but I just need wifi for now. Here's the wifi card:

000:55:00.0 Network controller: Qualcomm Device 1101 (rev 01)
    Subsystem: Bigfoot Networks, Inc. Device a501

Anyways just found Ubuntu 20.04 Killer AX500s DBS drivers support where they say the support for this wifi card lands on 5.9. I installed 5.9.10:

lz@dell:~$ uname -r
5.9.10-050910-lowlatency

and there's still no wifi.

Found nothing about this device on internet, and neither on the linux kernel. https://github.com/torvalds/linux/tree/master/drivers/net/wireless where's qualcomm or bigfoot here?

This thread looks promising: https://github.com/kvalo/ath11k-firmware/issues/4

I know that here: https://medium.com/@tomas.heiskanen/dell-xps-15-9500-wifi-on-ubuntu-20-04-d5f1c218e78a there's a way to install it from git by compiling, but I'm not confortable in installing things from random places.

So is there a way to make it work with the latest kernel?

UPDATE:

also tried

lz@dell:~$ uname -r
5.10.0-051000rc5-lowlatency

which is the latest possible. No sucess.

1

UNTESTED:

According to https://bugzilla.kernel.org/show_bug.cgi?id=211569#c3, while the driver is being developed and may work in parts if you have the latest kernel (5.11 or ubuntu's oem kernel), you can also try this second solution, that is:

Update BIOS to version 1.1.4 or newer

UPDATE:

tested and it works :)

3
  • Yep, in my case too. I have a Dell XPS 13 9310, updating the BIOS to version 2.0 fixed both wifi and bluetooth issues. Good luck – Christian Feb 16 at 15:52
  • @Christian my only problem now is when I close the lid, then take the usb-c charger out and replug after some hours and open the lid. Then it's all black and I have to force reboot. Did you experience any of that? I've been not taking the charger out for days and it works. Soon gonna start taking out to test, with different intervals. kernel 5.10.0-1013-oem – Guerlando OCs Feb 19 at 4:16
  • I didn't try this specific case yet. My workflow is usually either I start the laptop without charger, work a few hours, close the lid, connect the charger and reopen the lid. I'll try what you mentioned and let you know – Christian Feb 22 at 9:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.