0

Videos that are encoded with H.264 or VP8 codecs (possibly others too), regardless of the container (MKV, MP4, WEBM, etc), will only play audio in VLC, at least in Ubuntu 20.04. Interestingly, GNOME Video application will play those files just fine.

I've tried restarting the computer and let VLC run alone without any other user programs running concurrently to avoid interference. I've installed and reinstalled vlc, ubuntu-restricted-extras, ffmpeg, libdvdnav, libdvdread7, gstreamer1.0-libav and various other packages, clearing gstreamer cache and nothing changed. I've tried forcing VLC video demuxing to H264 video demuxer but I've got the following error VLC could not decode the format "h264" (H264 - MPEG-4 AVC (part 10)) which led me just to dead ends in Google Search.

What else can I try? I haven't found any other source in the web that have solved a case similar to mine.

1

I've finally found the problem: due to my HiDPI display I've installed gnome-tweak-tool, Tweaks, and changed font-scaling option to 2.00. I've tested reverting this back to 1.00, i.e. no font scaling, and VLC started working properly!

In the end, I had just to give-up using font-scaling and just setting the system fonts to higher sizes and adjusting the web browser default zoom to cope with this.

I've tested using display scaling, i.e. set it to 200% or similar, under Ubuntu Settings > Displays but that led to the same problem. So if you're using display scaling you can try turning it back to 100%.

For now I'm using display scaling and the workaround is to manually reverting scaling to 100% when I want to use VLC and set it back to 200% when I'm done.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.