0

Ubuntu 20.04.1 installed in my back up computer back in Sept. Worked fine over several tests, and uses including a few days ago. But yesterday, after a Ubuntu software upgrade, the screen just went black. Stayed black. No amount of keyboard key combinations, mouse movement or yelling at the black monitor made it come back. So did a hard reset. This system is 6 yo ASUS AMD Quad Core 64-bit. Standard setup, using the built-in video chip.

That reset behaved strangely, going to a repair screen. Eventually, I took a guess that there was a hardware issue, and guessed again that it might be the PS2 mouse driver. So pulled that mouse and plugged in a USB wireless mouse. That allowed the computer to boot, but it double pumps, every time. It cycles through, gets to the Gurb menu then reboots. IT DID NOT DO THIS BEFORE that upgrade. On the 2nd pass, it gets to the Gurb screen that allows me to choose Ubuntu 20.04 or Win10 and eventually boots.

So that's where it is now. It's usable with a USB mouse. I WANT TO BE ABLE TO USE THE PS2 MOUSE. But can't find any updated method to restore operation in 20.04.

And I'd like a way to fix the double boot sequence.

Anyone know how to restore the PS2 operation? THANKS!

PS I found this page...but have no idea what I'm suppose to do to restore operation...https://manpages.ubuntu.com/manpages/focal/man4/psm.4freebsd.html

22
  • Is it a ps/2 mouse plugged into a ps/2 port or usb via an adapter? Have you tried using a usb adapter?
    – xiota
    Nov 30 '20 at 15:21
  • @xiota: It is (was) plugged into a PS2 port. I cannot find my PS2 to USB adapter so I can't test that. Keep in mind that the PS2 mouse has worked fine for a couple months now. The upgrade trashed it. It's like there's no 20.04 recognition of PS2 hardware now.
    – Jim_HiTek
    Dec 1 '20 at 17:55
  • I don't have any computers with ps/2 port anymore. Try checking the psmouse module. Maybe it isn't loading or got blacklisted or something. Maybe also try a live cd to see if it works there. If it does, then there's definitely some sort of config issue.
    – xiota
    Dec 1 '20 at 18:58
  • @xiota: PSMouse module? I haven't loaded a PS2 mouse module (assume you mean the software, not the hardware module) for 20 odd years. Don't know where to find one. Can you link? Google isn't much help. I'll give the live CD a shot right now.
    – Jim_HiTek
    Dec 2 '20 at 18:28
  • @xiota: PS2 mouse works fine with the Live CD of 20.04.1. Rebooting gives this error message after almost 4 minutes of a black screen: AHCI Controller Unavailable. Then goes into a boot loop. Restarting with a USB mouse works fine. PS2 mouse works fine on my other ASUS mobo running 20.04.1 except it hasn't had any recent upgrades.
    – Jim_HiTek
    Dec 2 '20 at 19:12
0

RESOLVED INFO: I did submit a bug report back on Dec. 7th, 2020 and never heard back. What I did was go out and buy a USB keybord and a couple USB mice and that got me by. I could not find an ergonomic keyboard I wanted at that time! Both of my ergonomic keyboards are PS2 and using a PS2 to USB adapter never worked. I did test a few times in January and February and finally gave up on the PS2 connector that came with my motherboards, figuring it wouldn't ever work again with Ubuntu 20.04.

Then today, May 12, 2021; decided to test it one last time before tossing my PS2 keyboards and mice and HEY! my favorite keyboard works now!!

Took them I don't know how long but eventually the bug report worked I guess and Ubuntu 20.04.2 again recognizes and works with PS2 hardware. YEA!!

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.