I made a fresh 'easy install' of 12.04 on vmware workstation.

This is yet another problem (quite a few have been asked here.) with the vmware tools installation. I managed to install vmware tools manually. But I still end up at the terminal with a message - Terminal Login Screen

I have managed to change the default runlevel to 5 and have made sure that X11 common and lightdm are started at runlevel 5 (Used sysv-rc-conf & checkconfig). When I login, I am at runlevel 5, but lightdm or X server are not in the ps aux list.

What am I missing? how do I get rid of this message and start the graphical login manager?

PS: I installed a GB of other apps by logging in and really wanted to salvage it over reinstalling.

  • Not sure what went wrong here but i'd throw the VM into trash and do a fresh install without easy install. Just select other linux and configure it yourself - it's just like setting up Ubuntu on a real hardware.
    – sulaweyo
    May 1, 2012 at 20:20
  • I would have preferred that, but I logged in and installed a GB of other apps - xfce, build essentials, updates, kernel headers, eclipse etc. I would prefer to salvage this to redoing everything.
    – Lord Loh.
    May 1, 2012 at 20:27

2 Answers 2


Try this:

sudo -s
mv /etc/issue.backup /etc/issue
mv /etc/rc.local.backup /etc/rc.local
mv /opt/vmware-tools-installer/lightdm.conf /etc/init

This will restore these files from the backup that VMWare made durin VMWare tools installation.

  • Not a solution that I liked or used, but I have a poor acceptance ratio and had to choose one. The other answer here is not very helpful.
    – Lord Loh.
    Nov 14, 2013 at 3:08

use custom installation in vmware and don't install it through easy install.try that

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .