5

I have downloaded the stremio installation file from this website. On unpacking the .deb file (in Ubuntu 20.10 64 bit machine) it gives the following error:

Unpacking stremio (4.4.116-1) ...
dpkg: dependency problems prevent configuration of stremio:
 stremio depends on nodejs; however:
  Package nodejs is not installed.
 stremio depends on qml-module-qt-labs-platform (>= 5.9.5); however:
  Package qml-module-qt-labs-platform is not installed.
 stremio depends on qml-module-qtwebchannel (>= 5.9.5); however:
  Package qml-module-qtwebchannel is not installed.
 stremio depends on qml-module-qtwebengine (>= 5.9.5); however:
  Package qml-module-qtwebengine is not installed.
 stremio depends on libfdk-aac1 (>= 0.1.5); however:
  Package libfdk-aac1 is not installed.

dpkg: error processing package stremio (--install):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 stremio

To resolve the error or fix the missing dependencies, I ran the command sudo apt -f install. However this command does nothing other than just uninstalling the broken stremio installation.

Please help.

1 Answer 1

16

Try this bro, works for me

wget https://dl.strem.io/shell-linux/v4.4.116/stremio_4.4.116-1_amd64.deb
wget http://archive.ubuntu.com/ubuntu/pool/multiverse/f/fdk-aac/libfdk-aac1_0.1.5-1_amd64.deb 
sudo dpkg -i libfdk-aac1_0.1.5-1_amd64.deb
sudo apt install ./stremio_4.4.116-1_amd64.deb
3
  • Thanks. It worked.
    – Tanvir
    Dec 4, 2020 at 19:08
  • Thanks for indicating the source for libfdk-aac1 package which is no longer in the official repos, but you can remove or modify the first and last lines as it works with the later stremio versions as well.
    – Sadi
    Jan 1, 2021 at 9:46
  • Confirmed it's working in debian testing 11, but in addition you must install libx264.so.152 from ubuntu repository Feb 10, 2021 at 18:49

Not the answer you're looking for? Browse other questions tagged or ask your own question.