6

I can't see where I am in the pages since the color of the scrollbar is the same as the background ...

Can I change the color, maybe with ./gtk-2/apps/ff.rc ? I couldn't find anything about it.

Thanks.

4

My theme is Ambiance and I added

style "scrollbar" {
    bg[NORMAL]  = shade (0.9, @selected_bg_color)
    bg[SELECTED]    = shade (0.7, @selected_bg_color)
    bg[ACTIVE]  = shade (0.7, @selected_bg_color)
    bg[PRELIGHT]    = shade (0.7, @selected_bg_color)

    GtkScrollbar::trough-border = 2

    engine "murrine" {
        roundness   = 8
        border_shades   = {1.0, 1.0}

        contrast    = 0.0
    }
}

in ~/.theme/copy_of_the_Ambiance_theme/gtk-2.0/gtkrc after tweaking the shades and it worked.

1

Firefox 44.0.2 / Ubuntu 14.04 / NoiaScrollbars 1.2.4

The easiest way for noobs like me is to install an add-on for it.

NewScrollbars aka NoiaScrollbars does the trick.

update - Firefox scrollbars have been visible since at least Ubuntu 16.04 and this add-on does not seem compatible with newer versions of Firefox but I will leave this answer up for anybody still running 14.04.

0

Does this problem exist on all websites? It could be that a page is handling scroll bars within their code, or has overflow disabled in their html.

Do you have a theme applied? Check Tools > Add-ons > Appearance and switch to the default theme to double-check that this isn't the problem.

Do you have an extension (like NewScrollbars) or plug-in that might be altering the way Firefox scrollbars are handled? If so, disable them and try again.

If it is none of the above, Firefox uses the current desktop theme for its colors (including the scroll bar). Try switching your current desktop theme to the default--or at least to something different--to see if the problem is corrected.

2
  • It is none of the above and it's Ambiance with a white scrollbar on white background. Anyway, thanks to you, I did try other themes and found my answer which I'll post right now ;) – user50745 May 1 '12 at 22:45
  • Glad you found it! – Jim C May 1 '12 at 22:55
0

Firefox 73.0

The appearance of the Firefox scrollbars can be changed by creating a new gtk.css in the Firefox profile folder. For me this is located at ~snap/firefox/323/.config/gtk-3.0 , but it may have a different location if you don't have a snap version.

The gtk.css file should contain the following code to allow you to adjust the appearance of both the vertical and horizontal sliders:

scrollbar.vertical slider {

/* Slider dimensions */

min-width: 12px;
min-height: 70px;

/* Curvature top and bottom of the slider */

border-radius: 12px;

/* Padding around the slider */

border: 4px solid transparent;

/* Colour of the slider */

background-color: #666699;

}

scrollbar.horizontal slider {

/* Slider dimensions */

min-width: 70px;    
min-height: 12px;

/* Curvature top and bottom of the slider */

border-radius: 12px;

/* Padding around the slider */

border: 4px solid transparent;

/* Colour of the slider */

background-color: #666699;

}

Just play around with the values until you find something you like. There are various colour finders online which will give you the hexadecimal values for a given colour.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.