1

Good evening, I recently installed Ubuntu 20.04 LTS and I have a sound problem, I think it's coming from Pulseaudio.

The maximum volume is like limited to 50%. When I start the computer and I go on youtube, the max volume is quite low, until I type in the pulseaudio -k terminal. The sound cuts off a few seconds, before coming back to full power (100%, without saturation). But this is only true for the open google chrome instance and it only works with my browser + youtube (spotify and MPV don't emit any sound after pulseaudio -k).

I already tried to reinstall pulseaudio, to remove it... it always comes back to the same thing. It's quite annoying since the volume of movies on MPV is quite low on the base.

Do you have an idea where this can come from ? I already checked alsamixer, my sound card is ALC887-VD.

Any help appreciated, I'm new on linux. Thanks in advance.

  • I'd open pavucontrol and see if any of the volume sliders are limiting your output. That gets opened from the terminal in this case. So CTRL ALT T and then copy/paste that. A window will pop open and you can check in there. – KGIII Nov 24 '20 at 22:31
  • 1
    Thank you for your answer. I've been there, all sliders are at 100%. Below the navigator, the sound bar goes up to 50% max when listening, and when I kill pulseaudio, it goes up to 100% ... until I restart the navigator – Loïc Delon Nov 24 '20 at 22:44
  • I did a search for your soundcard and Linux, and there are many complaints and many proposed fixes - but none matches your symptoms. You might look here and some posts suggest the HWE stack which you can read about here. – KGIII Nov 24 '20 at 22:54
  • From the last link, more specifically, sudo apt-get install --install-recommends linux-generic-hwe-20.04 xserver-xorg-hwe-20.04 may be a fix. This is based on reading a couple of threads about it. – KGIII Nov 24 '20 at 22:56
  • I've just tried the command you sent, but I get three error messages telling me it's impossible to find "xserver-xorg-hwe-20.04"... I'm going to go look at the links you sent, thank you. – Loïc Delon Nov 24 '20 at 23:07
0

That's it, I think I've finally solved the problem. I use the green line output located behind the computer with my headphones (ubuntu detects it as a speaker output, which was maybe the reason of my too low max volume.

So I used hdajackretask to make the rear line output become a headphone output. On reboot, you can feel the difference on VLC and MPC (where the sound was really too low), on Chrome it didn't change (but the sound is enough).

My theory is the following: since ubuntu was detecting speakers instead of stereo headphones, the sound was maybe output in 5.1 or higher with VLC and MPC (where the max volume was too low), on youtube 5.1 is not available anymore since a few years I think.The sound still doesn't seem to be at 100%, but more around 75%, which is enough. Anyway, thanks for trying to help me KGIII.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.