0

enter image description hereIt comes up with message "Are you trying to play dvd without libdvdcss?" I have tried all the command line fixes listed including the one that says it's for Ubuntu 20 but all return variations on "not found". What am i missing? Screen grab was taken from response and cut/pasted directly into terminal

6
  • 1
    Does this answer your question? How can I play encrypted DVD movies? Dec 13 '20 at 10:17
  • Not really, as I said they will now play in Videos but VLC still refuses to play them.
    – Vic
    Dec 13 '20 at 11:39
  • Does this answer your question? How do I enable the "multiverse" repository?
    – karel
    Dec 17 '20 at 8:21
  • With the caveat above. Yes I have enabled “mutiverse” but NO the other half of the original question is unanswered ie VLC will not play the DVD.
    – Vic
    Dec 18 '20 at 9:09
  • are you in Ubuntu proper (gnome) using Nautilus as file manager? It's odd it says nothing when you insert the DVD.
    – cipricus
    Feb 23 at 13:51
2

libdvd-pkg is in the multiverse repository; you need to enable that.

:~$apt policy libdvd-pkg
libdvd-pkg:
  Installed: 1.4.2-1-1
  Candidate: 1.4.2-1-1
  Version table:
 *** 1.4.2-1-1 500
        500 [redacted]/us.archive.ubuntu.com/ubuntu bionic/multiverse amd64 Packages
        500 [redacted]/us.archive.ubuntu.com/ubuntu bionic/multiverse i386 Packages
        100 /var/lib/dpkg/status

On my system (not 20.10) this can be done on the "Software and Updates" page.

enter image description here After enabling multiverse, you will have to enter the following two commands one by one.

sudo apt install libdvd-pkg
sudo dpkg-reconfigure libdvd-pkg
2
  • Thank you that worked but it still won't play in VLC, although it does work in Videos now.
    – Vic
    Nov 24 '20 at 15:06
  • The OP has posted an answer that shows what the problem was really about: 1) no notification prompt/message upon insertion; 2) the OP was trying to play the DVD in VLC by opening individual files from the disk.
    – cipricus
    Feb 23 at 15:27
1

Have since found that you must "Open DVD" not an individual file on said DVD. VLC works if you do that doh!

5
  • Don't you get a message when you insert the DVD? You might be interested by this, this, this.
    – cipricus
    Feb 23 at 13:23
  • This answer clarifies your question. You should edit the question to make it clear that the problem was with you and VLC (hence your name I guess)
    – cipricus
    Feb 23 at 13:27
  • 1
    No message when DVD inserted and name is ironic arising from metal detecting.
    – Vic
    Feb 23 at 13:39
  • Sorry, my eyes are faulty, I read "vlc" :) I hope my answer will count as compensation for my lack of attention. (Please edit your question: you get good answers that have nothing to do with your problem, it is a waste of people's time).
    – cipricus
    Feb 23 at 14:08
  • As you say, libdvd-pkg in ubuntu 20.10 or any other OS has nothing to do with it.
    – cipricus
    Feb 23 at 14:16
1

Normally you should be asked what to do when inserting a DVD. If you are not, check the file manager settings.

Otherwise the command vlc dvd:// should run the DVD. You could associate that command with a shortcut, or create a launcher for it. If Gedit is your text editor (if you are in Ubuntu proper - Gnome), do this:

  • Create the folder ~/.local./share/applications (CTRL+h to see hidden files and folders)

  • Open terminal and run gedit ~/.local./share/applications/start_dvd_vlc (that should open the newly created file ~/.local./share/applications/start_dvd_vlc. If it doesn't then you have another text editor; you can replace gedit with that or install gedit with sudo apt install gedit).

Paste this:

[Desktop Entry]
Name=Play DVD in VLC media player
Exec=vlc dvd://
Icon=vlc
Terminal=false
Type=Application
Categories=AudioVideo;Player;Recorder;
Keywords=Player;Capture;DVD;Audio;Video;Server;Broadcast;

If you want a different icon for that, change the Icon line to the path to your icon. Take a look here. This might work:

enter image description here

Or this:

enter image description here

Save the file.

If you are interested in using other players, see this.

Use application launcher (Super key) with "VLC" or "DVD" to find the launcher "Play DVD in VLC media player".

I'm in Xfce, so it looks like this:

enter image description here

In Xfce, the Whisker Menu launcher can add a separate new "search action" that can run any command, including those discussed above:

enter image description here

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.