Using gparted, I created two 4096MB fat32 partitions on a 32GB USB flash drive, and then used unetbootin to install FD13LIVE.ISO on partition 1 using "ISO mode", and FD13FULL.IMG to partition 2 using "Floppy IMG" mode and rebooted.

After all the BIOS messages displayed, I got the error Missing Operating System. Obviously, I missed something, but what?

  • @karel NO, because I already did that. (At least, I think I did it; that's why I specified In the question what I did.)
    – RonJohn
    Nov 23, 2020 at 4:38
  • The problem with that statement is you didn't already do that. You specified In the question that you did something else instead. To be more specific you tried to install it using the unreliable UNetbootin application.
    – karel
    Nov 23, 2020 at 4:39
  • 4
    There have been a number of complaints with unetbootin, here and there on the various forums. I'd suggest trying a different application, just to eliminate that as a problem. I personally use Balena Etcher and get good results with it. If it doesn't work, you've eliminated the unetbootin as the cause and not wasted much time to do so.
    – KGIII
    Nov 23, 2020 at 4:44
  • 2
    @KGIII Balena allowed me to burn FD13FULL.IMG to a USB stick and boot into FreeDOS. Make that an answer and I'll gladly accept it.
    – RonJohn
    Nov 23, 2020 at 5:32
  • 2
    @RonJohn As a result of your prompt and aggressive follow-up of your own question there are currently no remaining duplicate close votes against your question. There was one duplicate close vote before which was mine and I retracted it. Please accept my apology for the inconvenience.
    – karel
    Nov 23, 2020 at 5:35

2 Answers 2


As of late, there have been numerous complaints about unetbootin not working. I do not know the specifics, but the end result is usually something like 'no operating system found'.

There is a solution. It's to use a different program. My personal favorite is Balena Echer.

You might also consider Mkusb. There's MultiBootUSB that is more aimed at multiple ISOs on one USB. The list goes on and you can search for alternatives. If you're using Windows, there are even more choices.


Installers that Work for FreeDOS

I tried a few popular OS installers with FreeDOS FD12FULL.img file. FreeDOS 1.2 was the latest version that I could find on the freedos.org site.

I formatted the USB flash drive as FAT32 and used the various tools to create an installer on the drive, then I booted the drives and used the FreeDOS installer to install on another flash drive.

The installer tools that worked for me were Unetbootin (Windows & Linux), Etcher (W&L), Rufus (W), Win32DiskImager (W), mkusb Live (L), SDC (L) and Gnome-Disks (L).

YUMI (W), Universal (W) and Ventoy (W&L) did not work with the FreeDOS image file.

  • 2
    1. It is obvious from your list that cloning tools work; 2. Others have failed with Unetbootin (which is not a cloning tool if I understand correctly). Please explain how you installed Unetbootin (and which version), and finally how you used it in order to make it work with FreeDOS.
    – sudodus
    Nov 24, 2020 at 14:04
  • 1
    @sudodus: I have used UNetbootin to install FreeDOS multiple times both from Windows and Ubuntu on a BIOS only computer. The OP says he is also pre-UEFI. It has worked on both one partition and two partition flash drives. Rufus also worked for me as did mkusb. The Pendrivelinux programs and Ventoy did not work, FreeDOS is not on their OS lists. I think they are ISO only programs, no IMG files allowed.. Today I will test a UNetbootin install on a UEFI computer. Nov 25, 2020 at 2:57

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .