21

Yesterday I upgraded my Ubuntu by SSH but before I finished it, I restarted my computer. I know that was not very smart. Anyway now I don't have internet connection, the WiFi or Ethernet is not recognized.

When I try on the latest version installed, the mice didn't work. When I try with previous version and go in gnome-network manager it's said:

The system network service is not compatible with this version

Another thing is when I comeback to the remote computer and look at the SSH terminal the process have stopped at:

Setting up desktop-file-utils (0.20-0ubuntu2) ... 
Configuration file `/etc/gnome/defaults.list' 
==> Modified (by you or by a script)
since installation. ==> Package distributor has shipped 
an updated version. What would you like to do about it ? 
Your options are: Y or I:install the package maintainer's 
version N or O : keep your currently-installed version D : 
show the differences between the versions Z : start a shell 
to examine the situation The default action is to keep your 
current version. * defaults.list (Y/I/N/O/D/Z) [default=N] ? 
Write failed: Broken pipe

Is there any simple solution other than I having to reinstall my system?

  • I'm getting the same problem with Ubuntu 14.04 – jeremiah Sep 7 '14 at 11:08
  • If on 14.04 LTS and you are facing problems after update in 2016 or later use this. I updated on 13th May 2016 and started facing this problem. askubuntu.com/a/771841/543358 This solved the problem without the need to downgrade. It will update network manager – Jit May 13 '16 at 14:47
15

Edit: This answer is over six years old and is no longer fresh due to changes in Ubuntu. This is a workaround.

Go into settings, startup items. Add an entry with the following command:

sudo service network-manager start

In a terminal, use visudo to add a NOPASSWD entry for this command so you do not need to give a password:

your-username-here ALL=NOPASSWD: service network-manager start

Next time you log on, this will force a start of the network manager (supposing that it is configured such that it can start up).

| improve this answer | |
  • 1
    It's not a very clean way... – nanofarad Jun 27 '12 at 22:52
  • Please describe what you mean by "clean". – jeremiah Sep 7 '14 at 11:06
  • 1
    @jeremiah it's basically a workaround that could be done at a more appropriate time such as one of many initialization boot scripts (although determining which to use is sometimes not trivial) – nanofarad Sep 7 '14 at 11:07
  • gksu was removed from Ubuntu, so this answer is not helpful for most folks. If you can, just open a command prompt and use sudo. – Mike T Feb 15 '19 at 21:46
  • @MikeT The problem with the use of pure-sudo is that a startup item probably won't get a proper PTY. I think that the best way to handle this would be to require the NOPASSWD entry so that the command can run fully-automatically. – nanofarad Feb 15 '19 at 22:01
18

I faced the same issue. Workaround is to start the network-manager manually

sudo service network-manager start

Still trying to figure a way to fix it permanently.

| improve this answer | |
  • I haven't found one besides reinstalling :/ – the_drow Nov 24 '13 at 12:27
  • Did you find the permanent way? – Jill Clover Feb 22 '14 at 10:55
  • 1
    For permanent fix (in ArchLinux) : sudo systemctl enable NetworkManager.service then sudo systemctl start NetworkManager.service – Fritzip Dec 29 '16 at 12:35
8

I had to reinstall the NetworkManager package and reboot. Everything was fine then.

sudo apt-get --reinstall install network-manager

| improve this answer | |
  • thanks @iGeorgie I am having ubuntu in Virtualbox.. This reinstallation of network manager worked for me :) – ravi.zombie Aug 11 '16 at 6:38
3

Just stick the following in /etc/rc.local before the line that says "exit":

NetworkManager

That should launch it whenever your system starts. A better way would be to add it to the appropriate init scripts so that it doesn't start in single user mode, but honestly it won't hurt anything this way either.

| improve this answer | |
3

I also had a partially-complete upgrade cause this issue, but my fix was different. Turns out that network-manager won't start at boot if any of the interfaces in /etc/network/interfaces marked auto don't come online. Basically, the static network configuration stuff should all come online before network-manager will be triggered. For me, this was a stray eth0 configured to use dhcp. I had unplugged the ethernet from my box, and suddenly this problem emerged. Solution was to remove everything but the loopback interface from /etc/network/interfaces. See this link for more info

| improve this answer | |
3

My install completed successfully, but I got the same error. Turns out that a new update (which reintroduces an old bug) causes network manager to crash. See here for the fix: Last upgrade crashes network manager (no internet connection, no applet)

| improve this answer | |
2

If the installation was interrupted, you might get good results by fixing it with

sudo apt-get install -f

I just had what I think was the same problem OP had, starting manually the Network Manager provided me with the icon in unity, but no interfaces visible, while the above mentioned command and a reboot fixed the issue completely.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.