0

Sound in VLC/Chrome/Firefox/Parole pauses or resumes after every 5 seconds. However, it works fine using aplay and paplay. VLC log:

nov 21 21:17:01 [00007f29c0c13bc0] main decoder debug: toggling resume
nov 21 21:17:01 [0000564a0ae7eb70] pulse audio output debug: changing sink 5: alsa_output.usb-C_T12L5V_USB_PnP_Audio_Device_U2dc0z7ws53a79rn-00.analog-stereo (USB PnP Audio Device Analog Stereo)
nov 21 21:17:01 [0000564a0ae856c0] dbus interface debug: Getting All properties
nov 21 21:17:02 [0000564a0ae856c0] dbus interface debug: Getting All properties
nov 21 21:17:03 [0000564a0ae856c0] dbus interface debug: Getting All properties
nov 21 21:17:04 [0000564a0ae856c0] dbus interface debug: Getting All properties
nov 21 21:17:05 [0000564a0ae856c0] dbus interface debug: Getting All properties
nov 21 21:17:06 [00007f29c0c13bc0] main decoder debug: toggling pause
nov 21 21:17:06 [0000564a0ae7eb70] pulse audio output debug: started
nov 21 21:17:06 [0000564a0ae7eb70] pulse audio output debug: changing sink 5: alsa_output.usb-C_T12L5V_USB_PnP_Audio_Device_U2dc0z7ws53a79rn-00.analog-stereo (USB PnP Audio Device Analog Stereo)
nov 21 21:17:06 [0000564a0ae856c0] dbus interface debug: Getting All properties

I have straced both working paplay and non-working cvlc, both seem to use /run/user/1000/pulse/native. However, a strace of cvlc shows this when the pause/resumes toggles (fd 10 is /run/user/1000/bus):

[pid 30556] 21:54:04 recvmsg(10, {msg_namelen=0}, MSG_CMSG_CLOEXEC) = -1 EAGAIN (Resource temporarily unavailable)

The sound card is a "Dinto" USC-C dock with built in sound. My other sound card works fine.

How to debug further? PA sinks:

>>> list-sinks
5 sink(s) available.
  * index: 0
    name: <alsa_output.usb-C_T12L5V_USB_PnP_Audio_Device_U2dc0z7ws53a79rn-00.analog-stereo>
    driver: <module-alsa-card.c>
    flags: HARDWARE HW_MUTE_CTRL HW_VOLUME_CTRL DECIBEL_VOLUME LATENCY DYNAMIC_LATENCY
    state: IDLE
    suspend cause: (none)
    priority: 9049
    volume: front-left: 0 /   0% / -inf dB,   front-right: 0 /   0% / -inf dB
            balance 0,00
    base volume: 64562 /  99% / -0,39 dB
    volume steps: 65537
    muted: no
    current latency: 33,03 ms
    max request: 11 KiB
    max rewind: 11 KiB
    monitor source: 0
    sample spec: s24le 2ch 48000Hz
    channel map: front-left,front-right
                 Stereo
    used by: 0
    linked by: 1
    configured latency: 40,00 ms; range is 0,50 .. 2000,00 ms
    card: 0 <alsa_card.usb-C_T12L5V_USB_PnP_Audio_Device_U2dc0z7ws53a79rn-00>
    module: 7
    properties:
        alsa.resolution_bits = "24"
        device.api = "alsa"
        device.class = "sound"
        alsa.class = "generic"
        alsa.subclass = "generic-mix"
        alsa.name = "USB Audio"
        alsa.id = "USB Audio"
        alsa.subdevice = "0"
        alsa.subdevice_name = "subdevice #0"
        alsa.device = "0"
        alsa.card = "1"
        alsa.card_name = "USB PnP Audio Device"
        alsa.long_card_name = "C&T12L5V USB PnP Audio Device at usb-0000:00:14.0-4.4.4, full speed"
        alsa.driver_name = "snd_usb_audio"
        device.bus_path = "pci-0000:00:14.0-usb-0:4.4.4:1.0"
        sysfs.path = "/devices/pci0000:00/0000:00:14.0/usb3/3-4/3-4.4/3-4.4.4/3-4.4.4:1.0/sound/card1"
        udev.id = "usb-C_T12L5V_USB_PnP_Audio_Device_U2dc0z7ws53a79rn-00"
        device.bus = "usb"
        device.vendor.id = "2000"
        device.vendor.name = "C&T12L5V"
        device.product.id = "dd00"
        device.product.name = "USB PnP Audio Device"
        device.serial = "C_T12L5V_USB_PnP_Audio_Device_U2dc0z7ws53a79rn"
        device.string = "front:1"
        device.buffering.buffer_size = "576000"
        device.buffering.fragment_size = "288000"
        device.access_mode = "mmap+timer"
        device.profile.name = "analog-stereo"
        device.profile.description = "Analog Stereo"
        device.description = "USB PnP Audio Device Analog Stereo"
        module-udev-detect.discovered = "1"
        device.icon_name = "audio-card-usb"
    ports:
        analog-output: Analog Output (priority 9900, latency offset 0 usec, available: unknown)
            properties:
                
    active port: <analog-output>
    index: 1
    name: <alsa_output.pci-0000_00_1f.3-platform-skl_hda_dsp_generic.HiFi__hw_sofhdadsp_5__sink>
    driver: <module-alsa-card.c>
    flags: HARDWARE DECIBEL_VOLUME LATENCY DYNAMIC_LATENCY
    state: IDLE
    suspend cause: (none)
    priority: 9037
    volume: front-left: 65536 / 100% / 0,00 dB,   front-right: 65536 / 100% / 0,00 dB
            balance 0,00
    base volume: 65536 / 100% / 0,00 dB
    volume steps: 65537
    muted: no
    current latency: 32,57 ms
    max request: 7 KiB
    max rewind: 7 KiB
    monitor source: 1
    sample spec: s16le 2ch 48000Hz
    channel map: front-left,front-right
                 Stereo
    used by: 0
    linked by: 1
    configured latency: 40,00 ms; range is 0,50 .. 341,00 ms
    card: 1 <alsa_card.pci-0000_00_1f.3-platform-skl_hda_dsp_generic>
    module: 8
    properties:
        alsa.resolution_bits = "16"
        device.api = "alsa"
        device.class = "sound"
        alsa.class = "generic"
        alsa.subclass = "generic-mix"
        alsa.name = ""
        alsa.id = "HDMI3 (*)"
        alsa.subdevice = "0"
        alsa.subdevice_name = "subdevice #0"
        alsa.device = "5"
        alsa.card = "0"
        alsa.card_name = "sof-hda-dsp"
        alsa.long_card_name = "DellInc.-XPS139310--0GG9PT"
        alsa.driver_name = "snd_soc_skl_hda_dsp"
        device.bus_path = "pci-0000:00:1f.3-platform-skl_hda_dsp_generic"
        sysfs.path = "/devices/pci0000:00/0000:00:1f.3/skl_hda_dsp_generic/sound/card0"
        device.bus = "pci"
        device.vendor.id = "8086"
        device.vendor.name = "Intel Corporation"
        device.product.id = "a0c8"
        device.string = "hw:sofhdadsp,5"
        device.buffering.buffer_size = "65472"
        device.buffering.fragment_size = "16320"
        device.access_mode = "mmap+timer"
        device.profile.name = "HiFi: hw:sofhdadsp,5: sink"
        device.profile.description = "HDMI3/DP3 Output"
        alsa.mixer_device = "hw:sofhdadsp"
        device.description = "sof-hda-dsp HDMI3/DP3 Output"
        module-udev-detect.discovered = "1"
        device.icon_name = "audio-card-pci"
    ports:
        [Out] HDMI3: HDMI3/DP3 Output (priority 700, latency offset 0 usec, available: no)
            properties:
                
    active port: <[Out] HDMI3>
    index: 2
    name: <alsa_output.pci-0000_00_1f.3-platform-skl_hda_dsp_generic.HiFi__hw_sofhdadsp_4__sink>
    driver: <module-alsa-card.c>
    flags: HARDWARE DECIBEL_VOLUME LATENCY DYNAMIC_LATENCY
    state: IDLE
    suspend cause: (none)
    priority: 9036
    volume: front-left: 68807 / 105% / 1,27 dB,   front-right: 68807 / 105% / 1,27 dB
            balance 0,00
    base volume: 65536 / 100% / 0,00 dB
    volume steps: 65537
    muted: no
    current latency: 36,91 ms
    max request: 7 KiB
    max rewind: 7 KiB
    monitor source: 2
    sample spec: s16le 2ch 48000Hz
    channel map: front-left,front-right
                 Stereo
    used by: 0
    linked by: 1
    configured latency: 40,00 ms; range is 0,50 .. 341,00 ms
    card: 1 <alsa_card.pci-0000_00_1f.3-platform-skl_hda_dsp_generic>
    module: 8
    properties:
        alsa.resolution_bits = "16"
        device.api = "alsa"
        device.class = "sound"
        alsa.class = "generic"
        alsa.subclass = "generic-mix"
        alsa.name = ""
        alsa.id = "HDMI2 (*)"
        alsa.subdevice = "0"
        alsa.subdevice_name = "subdevice #0"
        alsa.device = "4"
        alsa.card = "0"
        alsa.card_name = "sof-hda-dsp"
        alsa.long_card_name = "DellInc.-XPS139310--0GG9PT"
        alsa.driver_name = "snd_soc_skl_hda_dsp"
        device.bus_path = "pci-0000:00:1f.3-platform-skl_hda_dsp_generic"
        sysfs.path = "/devices/pci0000:00/0000:00:1f.3/skl_hda_dsp_generic/sound/card0"
        device.bus = "pci"
        device.vendor.id = "8086"
        device.vendor.name = "Intel Corporation"
        device.product.id = "a0c8"
        device.string = "hw:sofhdadsp,4"
        device.buffering.buffer_size = "65472"
        device.buffering.fragment_size = "16320"
        device.access_mode = "mmap+timer"
        device.profile.name = "HiFi: hw:sofhdadsp,4: sink"
        device.profile.description = "HDMI2/DP2 Output"
        alsa.mixer_device = "hw:sofhdadsp"
        device.description = "sof-hda-dsp HDMI2/DP2 Output"
        module-udev-detect.discovered = "1"
        device.icon_name = "audio-card-pci"
    ports:
        [Out] HDMI2: HDMI2/DP2 Output (priority 600, latency offset 0 usec, available: no)
            properties:
                
    active port: <[Out] HDMI2>
    index: 3
    name: <alsa_output.pci-0000_00_1f.3-platform-skl_hda_dsp_generic.HiFi__hw_sofhdadsp_3__sink>
    driver: <module-alsa-card.c>
    flags: HARDWARE DECIBEL_VOLUME LATENCY DYNAMIC_LATENCY
    state: IDLE
    suspend cause: (none)
    priority: 9035
    volume: front-left: 65536 / 100% / 0,00 dB,   front-right: 65536 / 100% / 0,00 dB
            balance 0,00
    base volume: 65536 / 100% / 0,00 dB
    volume steps: 65537
    muted: no
    current latency: 39,55 ms
    max request: 7 KiB
    max rewind: 7 KiB
    monitor source: 3
    sample spec: s16le 2ch 48000Hz
    channel map: front-left,front-right
                 Stereo
    used by: 0
    linked by: 1
    configured latency: 40,00 ms; range is 0,50 .. 341,00 ms
    card: 1 <alsa_card.pci-0000_00_1f.3-platform-skl_hda_dsp_generic>
    module: 8
    properties:
        alsa.resolution_bits = "16"
        device.api = "alsa"
        device.class = "sound"
        alsa.class = "generic"
        alsa.subclass = "generic-mix"
        alsa.name = ""
        alsa.id = "HDMI1 (*)"
        alsa.subdevice = "0"
        alsa.subdevice_name = "subdevice #0"
        alsa.device = "3"
        alsa.card = "0"
        alsa.card_name = "sof-hda-dsp"
        alsa.long_card_name = "DellInc.-XPS139310--0GG9PT"
        alsa.driver_name = "snd_soc_skl_hda_dsp"
        device.bus_path = "pci-0000:00:1f.3-platform-skl_hda_dsp_generic"
        sysfs.path = "/devices/pci0000:00/0000:00:1f.3/skl_hda_dsp_generic/sound/card0"
        device.bus = "pci"
        device.vendor.id = "8086"
        device.vendor.name = "Intel Corporation"
        device.product.id = "a0c8"
        device.string = "hw:sofhdadsp,3"
        device.buffering.buffer_size = "65472"
        device.buffering.fragment_size = "16320"
        device.access_mode = "mmap+timer"
        device.profile.name = "HiFi: hw:sofhdadsp,3: sink"
        device.profile.description = "HDMI1/DP1 Output"
        alsa.mixer_device = "hw:sofhdadsp"
        device.description = "sof-hda-dsp HDMI1/DP1 Output"
        module-udev-detect.discovered = "1"
        device.icon_name = "audio-card-pci"
    ports:
        [Out] HDMI1: HDMI1/DP1 Output (priority 500, latency offset 0 usec, available: no)
            properties:
                
    active port: <[Out] HDMI1>
    index: 4
    name: <alsa_output.pci-0000_00_1f.3-platform-skl_hda_dsp_generic.HiFi__hw_sofhdadsp__sink>
    driver: <module-alsa-card.c>
    flags: HARDWARE HW_MUTE_CTRL HW_VOLUME_CTRL DECIBEL_VOLUME LATENCY DYNAMIC_LATENCY
    state: RUNNING
    suspend cause: (none)
    priority: 9032
    volume: front-left: 26852 /  41% / -23,25 dB,   front-right: 26852 /  41% / -23,25 dB
            balance 0,00
    base volume: 65536 / 100% / 0,00 dB
    volume steps: 65537
    muted: no
    current latency: 22,33 ms
    max request: 4 KiB
    max rewind: 4 KiB
    monitor source: 4
    sample spec: s16le 2ch 48000Hz
    channel map: front-left,front-right
                 Stereo
    used by: 1
    linked by: 3
    configured latency: 23,22 ms; range is 0,50 .. 341,00 ms
    card: 1 <alsa_card.pci-0000_00_1f.3-platform-skl_hda_dsp_generic>
    module: 8
    properties:
        alsa.resolution_bits = "16"
        device.api = "alsa"
        device.class = "sound"
        alsa.class = "generic"
        alsa.subclass = "generic-mix"
        alsa.name = ""
        alsa.id = "HDA Analog (*)"
        alsa.subdevice = "0"
        alsa.subdevice_name = "subdevice #0"
        alsa.device = "0"
        alsa.card = "0"
        alsa.card_name = "sof-hda-dsp"
        alsa.long_card_name = "DellInc.-XPS139310--0GG9PT"
        alsa.driver_name = "snd_soc_skl_hda_dsp"
        device.bus_path = "pci-0000:00:1f.3-platform-skl_hda_dsp_generic"
        sysfs.path = "/devices/pci0000:00/0000:00:1f.3/skl_hda_dsp_generic/sound/card0"
        device.bus = "pci"
        device.vendor.id = "8086"
        device.vendor.name = "Intel Corporation"
        device.product.id = "a0c8"
        device.string = "hw:sofhdadsp"
        device.buffering.buffer_size = "65472"
        device.buffering.fragment_size = "16320"
        device.access_mode = "mmap+timer"
        device.profile.name = "HiFi: hw:sofhdadsp: sink"
        device.profile.description = "Speaker + Headphones"
        alsa.mixer_device = "hw:sofhdadsp"
        device.description = "sof-hda-dsp Speaker + Headphones"
        module-udev-detect.discovered = "1"
        device.icon_name = "audio-card-pci"
    ports:
        [Out] Speaker: Speaker (priority 100, latency offset 0 usec, available: unknown)
            properties:
                
        [Out] Headphones: Headphones (priority 200, latency offset 0 usec, available: yes)
            properties:
                
    active port: <[Out] Headphones>

Running Dell 9310 w/ Xubuntu 20.04 and kernel 5.6.0-1034-oem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.