1

I've installed Kubuntu 20.04 on my 13" 2009 MacBook Pro (model identifier MacBook Pro 5.5). This model has an Nvidia graphic card (GeForce 9400M). The native display resolution is 1280 x 800.

When I use the Nvidia driver (package nvidia-340), the KDE interface is ridiculously too big. I'm talking about the size of the desktop, widgets, window title bars, etc. This does not happen when I use the Nouveau driver (xserver-xorg-video-nouveau).

Here are some full screen screenshots that show what I'm talking about:
System settings (Nvidia): Nvidia_settings

System settings (Nouveau): Nouveau_settings

Lock screen (Nvidia): Nvidia_lock

Lock screen (Nouveau): Nouveau_lock


EDIT 23-11-2002 (new screenshots):
Display configuration (Nvidia): nvidia-display-conf

Display configuration (Nouveau): nouveau-display-conf


I'd like to know how to fix that. I want to use the Nvidia driver because my external display flickers like crazy with the nouveau driver (that's a separate problem...)

If that is relevant, I'm booting using the EFI stub loader through rEFInd.

What I've tried:

  • Booting through GRUB instead of the EFI stub loader
  • Booting with nodemodeset
  • Checking that the "global scaling" in the "Displays" section of the System Settings is at 100x
  • Changing the Rendering engine in the "Compositor" section from "OpenGL 2.0" to "OpenGL 3.1" or "XRender"

What I haven't tried yet (should I?):

  • Install another desktop manager and see if the problem persists
  • Install another display manager and see if the problem persists

Here are the exact versions of the drivers (the only two drivers listed by ubuntu-drivers devices):

Package: xserver-xorg-video-nouveau
Version: 1:1.0.16-1

Package: nvidia-340
Version: 340.108-0ubuntu2
2
  • I can't replicate this issue on my device with NVIDIA GPU and the most recent driver package nvidia-driver-450. Can you also upload a screenshot of the settings in the "Display Configuration" System Settings Module?
    – Nmath
    Nov 21 '20 at 22:15
  • I just added those screenshots. However as you can see the settings are the same in both cases...
    – philb
    Nov 23 '20 at 15:24
2

Have you tried change font DPI? In font settings set force DPI to 96 and reboot.

2
  • this seems to have worked! Wow thanks a ton !! for bonus points do you know why I need to set this manually for nvidia but not for nouveau ?
    – philb
    Nov 25 '20 at 16:26
  • You're welcome and thanks for points. I don't know how it works. Nov 28 '20 at 20:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.