1

I'm on Kubuntu 20.04.

If I double click a .txt file in Dolphin, or right click, open with Kate, I can see Kate briefly appear in the task manager, and then disappear, without ever having got to show its main window, or any dialogue with an error message, nor anything else. It doesn't write anything to the logs either.

If instead I open Kate from the "start menu" (Application Launcher), it opens OK. If I then use the menus, I can open the file I double clicked just normally.

If I open it from a terminal, either Konsole, or the terminal embedded in Dolphin, I can even open it as:

kate file.txt &

and it works fine. It just gives the following message on the terminal:

Hspell: can't open /usr/share/hspell/hebrew.wgz.sizes.
sonnet.plugins.hspell: HSpellDict::HSpellDict: Init failed

but then it works OK. (I don't use any hebrew... I have no idea where that came from).

How can I fix this? Where can I find more information about why it's crashing?

2
  • You could try purging kate and reinstalling it, eg in a console (like konsole) enter sudo apt purge ^kate && sudo apt install kate. That will purge any packages called "kate*" (which will be kate and kate5-data) and then reinstall kate. It looks like maybe your dolphin environment got set to use Hebrew? You might want to check the KDE language settings, userbase.kde.org/Tutorials/Change_Plasma_Language, first to make sure your preferred language is set. You can also check the file /usr/share/applications/org.kde.kate.desktop to make sure the language isn't set there. – pbhj Nov 25 '20 at 0:22
  • @pbhj Yes, that's basically what I did, as I wrote in my own answer. I just used Discover instead of apt, but it worked. About hebrew... I don't know what's the deal with that... I don't normally use it from the command line, so it doesn't bother me, but no, there's nothing about Hebrew in my language settings... Unless by virtue of some bug Hungarian is getting understood as Hebrew... But thanks for your input. – Wences Nov 26 '20 at 15:38
0

I uninstalled Kate using Discover, and then installed it again, and now it seems to be working. Frankly, it's a very "Windowsy" solution, and I still don't know what caused the problem in the first place, so I'm afraid it might happen again at any moment, but right now, it's working.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.